Bug 110305 - screen just doesn’t show correctly characters with accents...
screen just doesn’t show correctly characters with accents...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: screen (Show other bugs)
1
All Linux
high Severity high
: ---
: ---
Assigned To: Lon Hohberger
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 22:10 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-03 16:35:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-17 22:10:52 EST
Description of problem:
screen just doesn’t show correctly characters with accents...

Version-Release number of selected component (if applicable):
> rpm -q screen
screen-3.9.15-11

How reproducible:
outside screen:
sh-2.05b$ cat test 
á é í ó ú Á É Í Ó Ú 
à è ì ò ù À È Ì Ò Ù 
â ê î ô û Â Ê Î Ô Û
ã õ Ã Õ
sh-2.05b$ 

inside screen:
sh-2.05b$ cat test 
� � � � � � � � � � 
� � � � � � � � � � 
� � � � � � � � � �
� � � �
sh-2.05b$ 
  
Actual results:
Instead of accents it just dumps trash

Expected results:
To just show accents normally like all other screens on RH, Suse,
Mandrake or Solaris (probable any other *nix)

Additional info:
Any program with accents just gets completely screwed, for example, a
mail on pine (I installed it on fedora) outside screen works fine, is
not readable when it have any accents.

I’m Portuguese, so almost any text I see have accents, this makes
screen not usable, that’s why I putted the Severity on high.
Comment 1 Need Real Name 2003-11-17 22:20:55 EST
more characters that are not shown correctly:
outside screen:
´ « » º ª €
inside screen:
� � � � � �
Comment 2 Lon Hohberger 2003-11-18 09:13:57 EST
Did you try running "screen -U" ?
Comment 3 Need Real Name 2003-11-19 19:10:21 EST
I never needed that on any other distribution or even on Solaris.

Still I tried and nothing, same bogus output...
Comment 4 Mikko Paananen 2003-11-19 20:56:02 EST
Your locale settings are wrong, you are using unicode (UTF-8) locale
on terminal that does not support it. Screen tries to print unicode
characters but shows garbage on your terminal.

Switch to latin1/9 locale before starting screen (export
LC_CTYPE=pt_PT@euro), or

Get terminal that supports unicode. (If your terminal is Putty, set
translation to 'UTF-8'. Since you wrote that test file on non-unicode,
you have to recode your file to utf-8 with "iconv -f latin1 -t utf8 test")
Comment 5 Need Real Name 2003-11-20 03:35:00 EST
It did work...

It is strange because I’m using all the same configs I used on my old
Linux and on my Solaris. My accounts on bought Linux and Solaris are
mirrored regularly (the one on Linux is mirrored to the Solaris) and
It worked fine until fedora...

But thx for your time, since it is working now, I’ll keep that export...
Comment 6 Lon Hohberger 2003-12-03 16:35:27 EST
Solved w/ configuration change -> not a bug.

Reopen if locale settings fail in the future.

FYI - I hope to build screen 4.0.x soon :)

Note You need to log in before you can comment on or make changes to this bug.