Bug 110309 - up2date asks for registration every time, applet never shows updates
up2date asks for registration every time, applet never shows updates
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: 124619
  Show dependency treegraph
 
Reported: 2003-11-18 02:42 EST by K Kane
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-07 20:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description K Kane 2003-11-18 02:42:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
The panel applet never shows my system in need of updates, even when
they are available.  If I click on the applet, in addition to the
standard window, I get one requesting that I register with rhn.  If I
click the "register" button, the updater launches.

Version-Release number of selected component (if applicable):
up2date-4.1.16-1

How reproducible:
Always

Steps to Reproduce:
1.Click the rnh applet in the panel
2.Click the register option
    

Actual Results:  Asks me to register every time.  Applet never shows a
need to update.

Expected Results:  Applet should show the "red !" when packages are
available.  Registering should happen once, not each time.

Additional info:
Comment 1 J.B. Nicholson-Owens 2003-11-30 02:39:28 EST
I used Fedora Core 1's up2date and I could skip right past the
registration screen without supplying any information.  So, it would
appear you don't actually need to register anything to get Fedora Core
updates.  Therefore I would consider Fedora Core's up2date asking me
for registration information (at any time) to be a bug.
Comment 2 Chris Kuivenhoven 2004-09-04 16:37:29 EDT
Fedora Core 3 test 1 has the correct behavior; I think Fedora Core 2
worked fine with this as well, so I suspect this bug has been
resolved. Can either of you confirm?

Both behaviors seem to be fine now:

- up2date gnome applet does not ask for unnecessary registrations
- up2date watcher applet shos the "red !" when packages are available

-Chris Kuivenhoven
Comment 3 K Kane 2004-09-07 20:00:58 EDT
Sorry, I haven't used Fedora since FC1.  I'll close it.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.