Bug 110312 - switchdesk's idea of available sessions is different from gdm
switchdesk's idea of available sessions is different from gdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-18 05:28 EST by David Jansen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 07:13:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2003-11-18 05:28:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
Maybe this is not one bug, but a couple of related bugs

When selecting a session different from the users default in gdm, a
dialog pops up stating that this is a one time change, and directing
the user to switchdesk to set a permanent preference.
However, switchdesk presents a completely different set of available
desktops than the ones offered by gdm, and what's more, some of these
arent even present on my system (enlightenment, fvwm2 ; those are not
even present on the FC1 cds)

A related problem: switchdesk doesn't offer a way to get rid of these
preferences and return to using the system default, or the user's
.xsession (well, it does: when running switchdesk from an xterm you'll
get the advice "For system defaults, remove /home/user.Xclients", but
since most users will access switchdesk from the preferences menu,
this advice will go unnoticed)


Version-Release number of selected component (if applicable):
switchdesk-3.9.8-18 gdm-2.4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1.Run switchdesk from the preferences menu and select any session
other than Gnome or KDE
2.Log out
3.Wonder how to get rid of that switchdesk preference...
    

Actual Results:  switchdesk may have messed up your preferences (eg
when selecting a non-existent desktop like fvwm2) or it hardcoded your
preference as Gnome or KDE, with no easy way of returning to your own
customized .xsession

Expected Results:  switchdesk ought to present a list of existing
desktop environments, as well as a choice to return to using .xsession
(or System Default)

Additional info:

It would be ideal if switchdesk were aware of the files in
/etc/X11/dm/Sessions . Just finding the titles (for switchdesk's menu)
and Exec statements (for the .Xclients script it builds).
Comment 1 Ngo Than 2004-05-27 07:13:13 EDT
i have added selection of System defaults in switchdesk-4.0.4-1.
it will be showed up in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.