Bug 110319 - pci hotplug not enabled
Summary: pci hotplug not enabled
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-18 13:53 UTC by Matthew Wilcox
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 01:10:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Wilcox 2003-11-18 13:53:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031024 Debian/1.5-2

Description of problem:
willy@pourriel:~/kernels/rhel3/usr/src/linux-2.4.21-4.EL$ grep HOTPLUG
configs/kernel-2.4.21-ia64.config 
CONFIG_HOTPLUG=y
# CONFIG_HOTPLUG_PCI is not set
# CONFIG_HOTPLUG_PCI_COMPAQ_NVRAM is not set
# CONFIG_HOTPLUG_PCI_IBM is not set
# CONFIG_HOTPLUG_PCI_H2999 is not set
CONFIG_HOTPLUG_PCI_ACPI=m

since HOTPLUG_PCI_ACPI depends on HOTPLUG_PCI:

dep_tristate '  ACPI PCI Hotplug driver' CONFIG_HOTPLUG_PCI_ACPI
$CONFIG_ACPI $CONFIG_HOTPLUG_PCI

this configuration simply won't work.


Version-Release number of selected component (if applicable):
kernel-source-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1. look at the config file
2.
3.
    

Additional info:

Comment 1 Doug Ledford 2003-12-01 13:38:39 UTC
Config file changed in upcoming kernel update.

Comment 2 Ernie Petrides 2005-10-06 01:10:32 UTC
This was fixed in RHEL3 U1.


Note You need to log in before you can comment on or make changes to this bug.