Bug 110349 - [PATCH] pvmd3 segfaults under X86_64 arch in RHEL 3
Summary: [PATCH] pvmd3 segfaults under X86_64 arch in RHEL 3
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: pvm   
(Show other bugs)
Version: 3.0
Hardware: ia32e Linux
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2003-11-18 18:08 UTC by Neil Horman
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-02 03:24:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to correct type mis-definition in vfprintf and ctime to avlid SIGSEGV (2.42 KB, patch)
2003-11-18 18:10 UTC, Neil Horman
no flags Details | Diff

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:325 normal SHIPPED_LIVE Updated pvm packages fix segfault on AMD64 2004-09-01 04:00:00 UTC

Description Neil Horman 2003-11-18 18:08:51 UTC
Description of problem:
starting pvmd3, results in a SIGSEGV

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run pvmd3

Actual results:
daemon segfaults

Expected results:
daemon runs and listens for incomming pvm connections

Additional info:
This problem may be indicative of a larger problem with the library or
header file layout, as both segfaults which I observed and corrected
were the result of 64 bit pointers of which only the lower 32 bits
were filled out (the upper 32 bits were 0xffffffff).  I've managed to
fix both segfaults and get the daemon working again by strictly
including the appropriate files which the man pages for the
corresponding failing library calls indicate (stdarg.h in addition to
stdio.h for the vfprintf call, and time.h rather than sys/time.h for
the failing ctime call).  Without these modification, both these
library calls encounter pointer errors.

Comment 1 Neil Horman 2003-11-18 18:10:27 UTC
Created attachment 96043 [details]
patch to correct type mis-definition in vfprintf and ctime to avlid SIGSEGV

This patch repairs the two segfaults encountered in the description of this

Comment 2 Lon Hohberger 2003-12-02 20:43:20 UTC
Unfortunately, I think this scratches the surface of a much deeper
problem w/ pvm and x86-64.  I get other segfaults (particularly in the
exit path) even with the patch applied.

Comment 3 Lon Hohberger 2003-12-03 21:24:03 UTC
3.4.4-16 is in rawhide, including this patch.

Comment 4 Amit Bhutani 2004-06-22 17:11:21 UTC
RHEL3 U2 for AMD64 and EM64T product still contains pvm- 
which exhibits this bug. I am trying to get PVM to work on a Dell 
EM64T (ia32e) system. Here is the error message I am getting when I 
try to start PVM.

[root@localhost root]#pvm
libpvm [pid4648] mksocs() connect: No such file or directory
libpvm [pid4648] 	socket address tried: /tmp/pvmtmp004654.0
libpvm [pid4648] mksocs() connect: No such file or directory
libpvm [pid4648] 	socket address tried: /tmp/pvmtmp004654.0
libpvm [pid4648]: Console: Can't contact local daemon

Comment 5 Amit Bhutani 2004-06-22 22:58:31 UTC
BZ 123919 could be related to this issue.

Comment 6 Lon Hohberger 2004-06-23 15:03:24 UTC
It's the same issue.

Comment 7 Lon Hohberger 2004-06-24 20:01:14 UTC
Er, wow, I actually didn't apply the patch in 3.4.4-16.  I guess I
didn't drink enough coffee when I closed this the first time.

Comment 16 Jay Turner 2004-09-02 03:24:25 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.