Bug 110374 - The Internet Configuration Wizard (internet-druid) does not configure ADSL connections properly.
The Internet Configuration Wizard (internet-druid) does not configure ADSL co...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-18 17:08 EST by Thomas
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 21:40:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas 2003-11-18 17:08:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
The Internet Configuration Wizard (internet druid) asks for a provider
name when trying to configure an ADSL connection. It uses this name to
create the config file /etc/sysconfig/network-scripts/ifcfg-<name>,
but this file *must* have the name 'ifcfg-ppp0'.

So, the only way to configure an ADSL connection with the Internet
Configuration Wizard seems to be to give 'ppp0' as the 'provider name'.

Moreover, the 'Dial on Demand' does not work. The Internet
Configuration  Wizard puts the line 'DEMAND=yes' in ifcfg-ppp0. This
does not work (as in Red Hat 9). Solution: use e.g. DEMAND=600 (where
600 means: close connection after an idle time of 600 seconds). This
allows 'Dial on Demand' (but the connection will never get closed
automatically).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure an ADSL connection with the Internet Configuration Wizard
(GNOME) and use as 'provider name' something different from 'ppp0'
2. try to connect to the internet

    

Additional info:

The first bug ('provider name') seems to be new in Fedora Core 1,
whereas the second bug ('Dial on Demand') existed already in Red Hat 9.
Comment 1 Harald Hoyer 2003-11-25 11:07:38 EST
DEMAND=yes does not work?

$ fgrep -r DEMAND  /etc/sysconfig/network-scripts/
/etc/sysconfig/network-scripts/ifdown-ppp:if [ "${DEMAND}" = "yes" -a
-f /var/run/ppp-${CONFIG}.pid ] ; then
/etc/sysconfig/network-scripts/ifup-ppp:  if [ "${DEMAND}" != yes -a
"$TYPE" != "xDSL" ] ; then
/etc/sysconfig/network-scripts/ifup-ppp:if [ ${DEMAND} = yes ] ; then
Comment 2 Harald Hoyer 2003-11-25 11:08:51 EST
both bugs, should be initscript issues. reassigning
Comment 3 Bill Nottingham 2003-11-25 12:06:51 EST
The provider name stuff should be fixed in the current update in
testing, initscripts-7.42.1-1.
Comment 4 Olaf Rossner 2004-02-03 05:05:19 EST
Yes am experiencing the same.

Really anoying thing is that rh9 did it well and fedora doesn't.

I tried to put in my t-online account data since there is a special
form on fedora (the same as in rh9). I can't even enter the provider
data since I can't click on "OK".

When I setup a regular PPP then it will let me enter the data. Also
the i-net wizard works for the PPP connection.

One Activated I cannot access the internet. 

I saw a comment on this in this forum
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=110592

not sure if it works but will try and tell later...

Thx so far
Comment 5 Bill Nottingham 2004-03-16 21:44:37 EST
Does this persist after the initscripts update?
Comment 6 Bill Nottingham 2005-04-28 21:40:45 EDT
Closing, no response.

Note You need to log in before you can comment on or make changes to this bug.