Bug 110387 - ypbind can not find server with broadcast
Summary: ypbind can not find server with broadcast
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ypbind   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-18 23:22 UTC by matt poepping
Modified: 2007-11-30 22:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 04:30:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:433 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 3 Update 3 2004-09-02 04:00:00 UTC

Description matt poepping 2003-11-18 23:22:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When using ypbind in broadcast mode, it will never find a server. When
an address is specified its finds a server instantly.

This broadcast configuration has been working for us for all past
redhat versions, and has now just stopped working with rehdat ENT 3.0

When doing a packet capture on a good machine (7.3,8.9) the udp
checksum comes out correct. On a bad 3.0 machine the checksum of the
packet is incorrect.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set /etc/yp.conf to broadcast
2. /etc/init.d/ypbind start

    

Expected Results:  server will not bind.

Additional info:

Comment 1 Dave Maley 2003-12-03 18:42:45 UTC
output from ypbind configured for broadcast, running in debug mode:
---------------------------------------------------------------------

[root@xcopoepping40 root]# ypbind -debug
parsing config file
Trying entry: domain xilinx.com broadcast
parsed domain 'xilinx.com' broadcast
add_server() domain: xilinx.com, broadcast
[Welcome to ypbind-mt, version 1.12]
                                                                     
         
do_broadcast() for domain 'xilinx.com' is called
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
ypbindproc_domain_2_svc (xilinx.com)
Status: YPBIND_FAIL_VAL
broadcast: RPC: Timed out.
leave do_broadcast() for domain 'xilinx.com'
Pinging all active server.
do_broadcast() for domain 'xilinx.com' is called
                                                                     
         
-------
and this is when I staticaly assign the server name
                                                                     
         
[root@xcopoepping40 root]# ypbind -debug
parsing config file
Trying entry: domain xilinx.com server nis1.xilinx.com
parsed domain 'xilinx.com' server 'nis1.xilinx.com'
add_server() domain: xilinx.com, host: nis1.xilinx.com, slot: 0
[Welcome to ypbind-mt, version 1.12]
                                                                     
         
ping host 'nis1.xilinx.com', domain 'xilinx.com'
Answer for domain 'xilinx.com' from server 'nis1.xilinx.com'
ypbindproc_domain_2_svc (xilinx.com)
YPBINDPROC_DOMAIN: server '149.199.178.106', port 1023
Status: YPBIND_SUCC_VAL
Pinging all active server.

Comment 4 Neil Horman 2004-06-02 18:43:18 UTC
As it turns out, this is a duplicate of 124219

*** This bug has been marked as a duplicate of 124219 ***

Comment 5 John Flanagan 2004-09-02 04:30:57 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html



Note You need to log in before you can comment on or make changes to this bug.