This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 110393 - Scanner does not work in Fedora
Scanner does not work in Fedora
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-18 19:23 EST by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.0.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-27 12:12:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2003-11-18 19:23:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031117

Description of problem:
I'm unable to use the scanner in Fedora Core 1, I always get a "Error
during read: error during device I/O". The scanner does make a small
"head moving" noise before that error. It used to work in Red Hat 9,
now it doesn't.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run xsane
2.try to scan
3.wait
    

Actual Results:  "Error during read: error during device I/O"

Expected Results:  Should scan ok.

Additional info:

I have Fedora Core 1 with the latest updates.
The output from "scanimage --list-devices" is:
"device `plustek:/dev/usb/scanner0' is a Mustek BearPaw 1200 USB
flatbed scanner"
Comment 1 Carlos Rodrigues 2003-11-18 22:23:06 EST
I downloaded the source rpm and rebuilt it. Works fine now.
Comment 2 Tim Waugh 2003-11-19 06:35:41 EST
That doesn't help me figure out what the problem is. :-)

What about if you rebuild the source RPM and install the binary packages?
Comment 3 Carlos Rodrigues 2003-11-19 10:51:52 EST
I did install the rebuilt binary packages... that was the whole point
on rebuilding the source RPM... :) There is one thing though, I didn't
try this before upgrading the glibc so I don't know if it worked
before the upgrade.
Comment 4 Tim Waugh 2003-11-19 11:03:22 EST
Sorry, missed the important word 'rpm' from your comment -- thought
you'd grabbed the tarball and started from that!

Well, can you re-install the pre-built packages and see if they still
fail?
Comment 5 Carlos Rodrigues 2003-11-19 17:16:31 EST
I tried to scan again and now I get the same error with the packages
that I rebuilt... I reinstalled the pre-built packages and I still get
the error.
Comment 6 Tim Waugh 2003-11-20 07:55:40 EST
Did you have Red Hat Linux 9 on this machine, or another release, and
did the scanner work then?
Comment 7 Carlos Rodrigues 2003-11-20 08:53:03 EST
Yes, in fact my previous Red Hat 9 installation is still alive on
another partition and the scanner works there. Here's what I did just now:

1. Tried scanning using "scanimage". I got the error message.
2. Booted into Red Hat Linux 9, tried scanimage, it said that there
were no devices.
3. Tried with xsane, it worked ok.
4. Booted into FC1, tried xsane and scanimage, both of them work now
(thinking of it, I think that before I rebuilt sane-backends I had
just been trying the scanner in RHL9, maybe that was the reason it
worked).
Comment 8 Tim Waugh 2003-11-21 12:01:41 EST
So what do you have to do to make it no longer work?
Comment 9 Carlos Rodrigues 2003-11-21 12:58:12 EST
I tried to:

1. Reboot the computer;
2. Reset the computer;
3. Poweroff the computer;
4. Unplugging the scanner from the computer and plug it back;
5. Powering off the scanner and power it back on (pulling the power
plug from the scanner).

Conclusion: only step 5. made the scanner stop working in fedora, all
the others made no difference (the scanner kept on working after I had
previously tried to scan under RHL9).
Comment 10 Tim Waugh 2003-11-22 18:12:52 EST
Is /etc/sane.d/plustek.conf different between the Red Hat Linux 9
installation and the Fedora Core 1 installation?
Comment 11 Carlos Rodrigues 2003-11-23 18:00:33 EST
No. They are the same.
Comment 12 Carlos Rodrigues 2003-11-23 19:41:50 EST
Ok, I just downloaded the recently released sane-backends 1.0.13. I
threw it in the SRPM from fedora (had to make some changes to the
sane-backends-1.0.7-autoload.patch) and rebuilt it. It appears to be
working now (fingers crossed), last time I tried (with the fedora
pre-built RPM) it didn't work and I didn't reboot or anything since
then. Additionally I pulled the power plug from the scanner and put it
back, it kept working.
Comment 13 Tim Waugh 2003-11-27 12:12:00 EST
Okay, great.

Note You need to log in before you can comment on or make changes to this bug.