Bug 11041 - File system corruption with new kernel 2.2.14-6.0.1
Summary: File system corruption with new kernel 2.2.14-6.0.1
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-25 19:02 UTC by benjamin-redhat
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 03:09:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description benjamin-redhat 2000-04-25 19:02:38 UTC
After losing my file system to corruption four times with default 6.2
installs I found the update RHBA-2000:013-01.  I installed the fix and
tested it by banging the hell out of my system.  It seemed to work.  Over
the next day or so I rebooted many times and did a number of compiles, etc
that made the system page.  I rebooted it and left it running while I left
town for a couple of days and came back to find a bunch of EXT2-fs errors
on my console.  Rebooting is like before.  It brings you up into single
user mode and when you run fsck on the fs you get millions of errors and
most of your files end up in lost+found.

I am running a full 6.2 install with all updates on a dual PIII system with
256mb of RAM and an IDE hard drive.

One common thing I noticed in the log files is that the errors start
cropping up at 4:02am as cron.daily is running.  There are a couple of
scripts in there that couple be pretty i/o intensive.

Here is the contents of my /var/log/messages:

Apr 23 04:02:01 neuromancer anacron[843]: Updated timestamp for job
`cron.daily' to 2000-04-23
Apr 23 04:02:02 neuromancer syslogd 1.3-3: restart.
Apr 23 04:02:02 neuromancer syslogd 1.3-3: restart.
Apr 23 04:02:03 neuromancer syslogd 1.3-3: restart.
Apr 23 04:02:03 neuromancer syslogd 1.3-3: restart.
Apr 23 04:02:03 neuromancer syslogd 1.3-3: restart.
Apr 23 04:02:29 neuromancer kernel: locknr=-871099916 sector=1621135264
size=4096 count=1
Apr 23 04:02:29 neuromancer kernel: EXT2-fs error (device ide0(3,5)):
ext2_readdir: directory #356225 contains a hole at offset 443846656
Apr 23 04:02:29 neuromancer kernel: attempt to access beyond end of device
Apr 23 04:02:29 neuromancer kernel: 03:05: rw=0, want=810567636,
limit=10490413
Apr 23 04:02:29 neuromancer kernel: dev 03:05 blksize=4096
blocknr=-871099916 sector=1621135264 size=4096 count=1
Apr 23 04:02:29 neuromancer kernel: EXT2-fs error (device ide0(3,5)):
ext2_readdir: directory #356225 contains a hole at offset 443850752
Apr 23 04:02:29 neuromancer kernel: attempt to access beyond end of device
Apr 23 04:02:29 neuromancer kernel: 03:05: rw=0, want=810567636,
limit=10490413
Apr 23 04:02:29 neuromancer kernel: dev 03:05 blksize=4096
blocknr=-871099916 sector=1621135264 size=4096 count=1
Apr 23 04:02:29 neuromancer kernel: EXT2-fs error (device ide0(3,5)):
ext2_readdir: directory #356225 contains a hole at offset 443854848
...
...
Apr 23 04:03:11 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405262
Apr 23 04:03:11 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404857
Apr 23 04:03:11 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404858
Apr 23 04:03:11 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404867
Apr 23 04:03:15 neuromancer kernel: EXT2-fs warning (deviceide0(3,5)):
ext2_free_inode: bit already cleared for inode 404801
Apr 23 04:03:15 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404871
Apr 23 04:03:15 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404958
Apr 23 04:03:15 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404963
Apr 23 04:03:15 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 404973
Apr 23 04:03:15 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405052
...
...
Apr 24 04:02:01 neuromancer anacron[6542]: Updated timestamp for job
`cron.daily' to 2000-04-24
Apr 24 04:02:13 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405583
Apr 24 04:02:13 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405280
Apr 24 04:02:13 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405060
Apr 24 04:02:13 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405294
Apr 24 04:02:13 neuromancer kernel: EXT2-fs warning (device ide0(3,5)):
ext2_free_inode: bit already cleared for inode 405297

I cat'd everything in /proc before shutting down the system and have the
full text of these logs if needed.

Comment 1 SB 2000-04-29 02:11:59 UTC
What brand harddrive? How new? and what EIDE/IDE card do you have?(I have
nothing to do with RedHat staff I have had similar problems on some fairly new
drives)

-Stan Bubrouski

Comment 2 gunkel 2000-05-02 13:39:59 UTC
Drive was a Maxtor 27gb 5400 rpm IDE (I don't have the model number handy).  The
controller is the onboard controller on a Tyan Tiger 100 (S1832DL) motherboard.

Comment 3 Michael K. Johnson 2000-07-31 21:07:40 UTC
Have you tried 2.2.16-3 from the errata?  fsck the partition to make
sure it is sane, make sure you do not have interrupts enabled for
that hard drive, and try the latest errata kernel.

Comment 4 Alan Cox 2000-08-08 21:06:18 UTC
These are more consistant with memory corruption than I/O problems in all
honesty. It looks like
hw though. Does the box pass memtest86

Comment 5 Mihai Radu 2000-09-20 19:14:16 UTC
I'm having the same kond of problems :
from /var/log/messages:

Sep 11 04:02:19 proteus kernel: EXT2-fs warning (device ide1(22,1)):
ext2_free_blocks: bit already cleared for block 4724586 
Sep 11 04:02:19 proteus kernel: EXT2-fs warning (device ide1(22,1)):
ext2_free_inode: bit already cleared for inode 2351256 

It's running on a dual PIII 450, 256 Mb Ram, 6gb system hdd & 30 Gb data drive
w/ kernel-smp-2.2.16-3

These problems killed the system a couple of times, after witch I had to fsck
the mounts & repair the errors that showed up.

I had to go back to a single-processor 2.2.14-15 kernel to have these errors
dissapear

Comment 6 Alan Cox 2002-12-14 22:56:33 UTC
Closed - no answer so assuming it failed memtest86



Note You need to log in before you can comment on or make changes to this bug.