Bug 110414 - traceroute udp ports
traceroute udp ports
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: traceroute (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 07:14 EST by Need Real Name
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-21 14:50:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-19 07:14:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I have two boxes here running rh 7.3 with the same traceroute package,
same kernel...etc etc. The problem is that one box uses 32769:65535
udp port (as source ports) range when I do a traceroute and the other
box use 1024:65535 udp range (as source ports).

I didn't any other parameter of the box.
Why the second box is using a differente port range?
md5sum signatures are the same.
The second box forces me to change my firewall!! :(

Version-Release number of selected component (if applicable):
traceroute-1.4a12-2

How reproducible:
Always

Steps to Reproduce:
1. run traceroute and tcpdump in the boxes
2. compare the results of tcpdump
    

Actual Results:  Second box must do traceroutes to internet but it is
not able to do that because the firewall rules. Traceroute is using
incorrect source ports

Expected Results:  Traceroute must use 32769:65535 udp ports

Additional info:
Comment 1 Radek Vokal 2004-11-21 14:50:35 EST
Try to use traceroute with -p to specify the port range. It seems that
sth else is listening on specific UDP ports so the range is changed. 

Note You need to log in before you can comment on or make changes to this bug.