Bug 110415 - ifup misses valid interfaces in modprobe.conf
ifup misses valid interfaces in modprobe.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 07:52 EST by Pontus Fuchs
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.44-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 01:18:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch for the problem (420 bytes, patch)
2003-11-19 08:07 EST, Pontus Fuchs
no flags Details | Diff

  None (edit)
Description Pontus Fuchs 2003-11-19 07:52:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
My modprobe.conf contains:

install eth1 custom-command-to-setup-interface

but ifup fails to load this module. The problem is in the
is_available function in /etc/sysconfig/network-scripts/network-functions

this function does:

alias=`modprobe -c | awk "/^alias $1 / { print \\$3 }"`

and will not recognice the install directive correctly

Version-Release number of selected component (if applicable):
initscripts-7.42-1

How reproducible:
Always

Steps to Reproduce:

    

Additional info:
Comment 1 Pontus Fuchs 2003-11-19 08:07:56 EST
Created attachment 96054 [details]
A patch for the problem
Comment 2 Bill Nottingham 2004-01-28 01:18:06 EST
Fixed thusly:

@@ -174,8 +174,8 @@
     LC_ALL= LANG= ip -o link | grep -q $1
     [ "$?" = "1" ] || return 0
  
-    alias=`modprobe -c | awk "/^alias $1 / { print \\$3 }"`
-    if [ -z "$alias" -o "$alias" = "off" ]; then
+    alias=`modprobe -c | awk "/^(alias|install) $1 / { print \\$3 }"`
+    if [ -z "$alias" -o "$alias" = "off" -o "$alias" = "/bin/true" ];
then
         return 2
     fi
     HOTPLUG=`cat /proc/sys/kernel/hotplug`
Comment 3 Bill Nottingham 2004-01-28 01:18:26 EST
Will be in 7.44-1.

Note You need to log in before you can comment on or make changes to this bug.