Bug 110454 - when booting, not displayed and ugly XWindow in vesa framebuffer
Summary: when booting, not displayed and ugly XWindow in vesa framebuffer
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-19 17:21 UTC by sangu
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.6.5-1.347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-02 14:44:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (8.09 KB, text/plain)
2003-11-19 17:22 UTC, sangu
no flags Details
scanpci message (1.35 KB, text/plain)
2003-11-19 17:23 UTC, sangu
no flags Details
XFree86 log (98.45 KB, text/plain)
2003-11-19 17:24 UTC, sangu
no flags Details
ugly X Window (388.36 KB, image/png)
2003-11-19 17:26 UTC, sangu
no flags Details
Sceenshot in NoAccel option (447.66 KB, image/jpeg)
2004-02-24 12:41 UTC, sangu
no flags Details
XFree86.0.log in NoAccel option (36.04 KB, text/plain)
2004-02-24 12:46 UTC, sangu
no flags Details
Screenshot in Accel Option (577.97 KB, image/png)
2004-02-24 12:48 UTC, sangu
no flags Details
XFree86.0.log in Accel Option (36.53 KB, text/plain)
2004-02-24 12:54 UTC, sangu
no flags Details
kernel-2.6.3-1.100 in noframebuffer (7.95 KB, text/plain)
2004-02-24 13:48 UTC, sangu
no flags Details
This problem happen in kernel-2.6.3-2.1.238 (916.54 KB, image/png)
2004-03-05 14:45 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.3-2.1.238 and Accel option is true (99.10 KB, text/plain)
2004-03-05 14:49 UTC, sangu
no flags Details
/boot/grub/menu.lst vga=0x31B (8.13 KB, text/plain)
2004-03-06 06:05 UTC, sangu
no flags Details
XFree86.0.log /boot/grub/menu.lst vga=0x31B (99.10 KB, text/plain)
2004-03-06 06:08 UTC, sangu
no flags Details
dmeag in /boot/grub/menu.lst novesa option (7.72 KB, text/plain)
2004-03-06 06:09 UTC, sangu
no flags Details
XFree86.0.log in /boot/grub/menu.lst no vesa option (99.10 KB, text/plain)
2004-03-06 06:13 UTC, sangu
no flags Details
XFree86.0.log in kernel 2.6.3-2.1.241 (99.10 KB, text/plain)
2004-03-07 01:37 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.3-2.1.242 (99.10 KB, text/plain)
2004-03-07 01:53 UTC, sangu
no flags Details
XFree86.0.log in kernel 2.6.3-2.1.246 (99.10 KB, text/plain)
2004-03-09 14:10 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.3-2.1.252 (99.10 KB, text/plain)
2004-03-10 04:00 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.3-2.1.253 (99.10 KB, text/plain)
2004-03-10 13:48 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.4-1.257 (99.10 KB, text/plain)
2004-03-12 00:47 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.4-1.278 (99.36 KB, text/plain)
2004-03-21 04:08 UTC, sangu
no flags Details
XFree86.0.log in kernel 2.6.4-1.279 (99.36 KB, text/plain)
2004-03-22 02:44 UTC, sangu
no flags Details
XFree86.0.log in kernel 2.6.4-1.286 (99.35 KB, text/plain)
2004-03-23 16:50 UTC, sangu
no flags Details
XFree86.0.log in Kernel-2.6.5-1.308 (37.71 KB, text/plain)
2004-04-08 05:23 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.5-1.314 (99.38 KB, text/plain)
2004-04-09 15:33 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.5-1.315 (99.38 KB, text/plain)
2004-04-10 01:22 UTC, sangu
no flags Details
XFree86.0.log in kernel-2.6.5-1.315.i586 (37.24 KB, text/plain)
2004-04-10 11:06 UTC, sangu
no flags Details

Description sangu 2003-11-19 17:21:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ko-KR; rv:1.5)
Gecko/20031016 Epiphany/1.0.6

Description of problem:
/boot/menu.list

title Fedora Core (2.6.0-0.test9.1.90)
	root (hd0,6)
	kernel /boot/vmlinuz-2.6.0-0.test9.1.90 ro root=LABEL=/ hdc=ide-scsi
acpi=on vga=0x31B rhgb
	initrd /boot/initrd-2.6.0-0.test9.1.90.img

when booting in vesa framebuffer, Not displayed and ugly xwindow 

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test9.1.90

How reproducible:
Always

Steps to Reproduce:
1. select kernel-2.6.0-0.test9.1.90 in grub
2.when booting, not displayed
3. login ( in console, i not use gdm)
4. startx, see ugly xwindow.   

Additional info:

in kernel-2.4.22-1.2115.ptl, good

vga savage2000, asus 694z mainboard,

Comment 1 sangu 2003-11-19 17:22:08 UTC
Created attachment 96059 [details]
dmesg

Comment 2 sangu 2003-11-19 17:23:16 UTC
Created attachment 96060 [details]
scanpci message

Comment 3 sangu 2003-11-19 17:24:20 UTC
Created attachment 96061 [details]
XFree86 log

Comment 4 sangu 2003-11-19 17:26:53 UTC
Created attachment 96062 [details]
ugly X Window

AA Font ugly and AA OFF Font good

Comment 5 Mike A. Harris 2003-11-19 20:06:38 UTC
Does disabling 2D accel, by using the following option change anything?

Option "noaccel"

Put it in the device section of the X config file.

Comment 6 sangu 2003-12-22 04:23:37 UTC
thank your comments. no problem in kernel-2.6.0-0.1.14.


Comment 7 sangu 2004-02-24 12:28:13 UTC
This problem(ugly AA Font) rehappen in kernel-2.6.3-100.


Fedora Development XFree86-4.3.0-59


Comment 8 sangu 2004-02-24 12:35:51 UTC
Added NoAccel option, this problem happen,too

Comment 9 sangu 2004-02-24 12:41:55 UTC
Created attachment 97987 [details]
Sceenshot in NoAccel option

kernel 2.6.3-1.100, XFree86 4.3.0-59

Comment 10 sangu 2004-02-24 12:46:38 UTC
Created attachment 97988 [details]
XFree86.0.log in NoAccel option

Comment 11 sangu 2004-02-24 12:48:03 UTC
Created attachment 97989 [details]
Screenshot in Accel Option

Comment 12 sangu 2004-02-24 12:51:58 UTC
Comment on attachment 97988 [details]
XFree86.0.log in NoAccel option

XFree86.0.log in NoAccel option

Comment 13 sangu 2004-02-24 12:54:32 UTC
Created attachment 97991 [details]
XFree86.0.log  in Accel Option

Comment 14 Dave Jones 2004-02-24 13:20:38 UTC
what happens if you remove the vga=0x31B from your grub config ?


Comment 15 sangu 2004-02-24 13:48:15 UTC
Created attachment 97993 [details]
kernel-2.6.3-1.100 in noframebuffer

Removed the vga=0x31B from grub config, the same promblem(AA ugly font)
happenes. 

But this problem doesn't happen in kernel 2.6.3-1.97.

Comment 16 sangu 2004-02-25 13:07:06 UTC
This problem doesn't happen in kernel-2.6.3-1.106

Comment 17 Mike A. Harris 2004-02-25 18:04:56 UTC
"CURRENTRELEASE" is Fedora Core 1, and this problem is not present
nor fixed in Fedora Core 1.  It's fixed in rawhide.

Reopening and reclosing as 'RAWHIDE'

Comment 18 sangu 2004-03-05 14:45:15 UTC
Created attachment 98314 [details]
This problem happen in kernel-2.6.3-2.1.238

AA fonts and icons are broken.

Comment 19 sangu 2004-03-05 14:49:44 UTC
Created attachment 98315 [details]
XFree86.0.log in kernel-2.6.3-2.1.238 and Accel option is true

Comment 20 sangu 2004-03-06 06:02:57 UTC
This problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.3-2.1.240.i686.rpm

AA fonts and icons are broken.

Comment 21 sangu 2004-03-06 06:05:48 UTC
Created attachment 98331 [details]
/boot/grub/menu.lst vga=0x31B

Comment 22 sangu 2004-03-06 06:08:01 UTC
Created attachment 98332 [details]
XFree86.0.log /boot/grub/menu.lst vga=0x31B

Comment 23 sangu 2004-03-06 06:09:19 UTC
Created attachment 98333 [details]
dmeag in /boot/grub/menu.lst novesa option

Comment 24 sangu 2004-03-06 06:13:04 UTC
Created attachment 98334 [details]
XFree86.0.log in /boot/grub/menu.lst no vesa option

The same problem happens in both novesa and vesa option.

Comment 25 sangu 2004-03-07 01:37:02 UTC
Created attachment 98349 [details]
XFree86.0.log in kernel 2.6.3-2.1.241

The same problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.3-2.1.241.i686.rpm

Comment 26 sangu 2004-03-07 01:53:10 UTC
Created attachment 98350 [details]
XFree86.0.log in kernel-2.6.3-2.1.242

The same problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.3-2.1.242.i686.rpm

Comment 27 sangu 2004-03-09 14:10:20 UTC
Created attachment 98401 [details]
XFree86.0.log in kernel 2.6.3-2.1.246

The same problem happens in fedora development kernel-2.6.3-2.1.246.

Comment 28 sangu 2004-03-10 04:00:24 UTC
Created attachment 98418 [details]
XFree86.0.log in kernel-2.6.3-2.1.252

The same problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-smp-2.6.3-2.1.252.i686.rpm

Comment 29 sangu 2004-03-10 13:48:05 UTC
Created attachment 98425 [details]
XFree86.0.log in kernel-2.6.3-2.1.253

The same problem happens in fedora development kernel-2.6.3-2.1.253

Comment 30 sangu 2004-03-12 00:47:52 UTC
Created attachment 98475 [details]
XFree86.0.log in kernel-2.6.4-1.257

The same problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.257.i686.rpm

Comment 31 sangu 2004-03-21 04:08:54 UTC
Created attachment 98723 [details]
XFree86.0.log in kernel-2.6.4-1.278

The same problem happen in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-smp-2.6.4-1.278.i686.rpm


X server is xorg-x11-0.0.6.6-0.0.2004_03_11.6.

Comment 32 sangu 2004-03-22 02:44:27 UTC
Created attachment 98742 [details]
XFree86.0.log in kernel 2.6.4-1.279

The same problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.279.i686.rpm

Comment 33 sangu 2004-03-23 16:50:21 UTC
Created attachment 98787 [details]
XFree86.0.log in kernel 2.6.4-1.286

The same problem happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.286.i686.rpm

Comment 34 sangu 2004-03-25 17:54:32 UTC
Both kernel-2.6.4-2.288.i686.rpm and kernel-2.6.4-2.290, the same
problem( AA font, icon and mouse cursor are crushed) happens.

Comment 35 sangu 2004-03-29 17:58:58 UTC
The same
problem( AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.294.i686.rpm

Comment 36 sangu 2004-03-30 03:54:53 UTC
The same
problem( AA font, icon and mouse cursor are crushed ) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.298.i686.rpm.

Please see: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=119347

Comment 37 sangu 2004-03-31 01:12:58 UTC
The same
problem (AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.300.i686.rpm.

Comment 38 sangu 2004-04-01 18:07:00 UTC
The same
problem (AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.4-1.302.i686.rpm.



Comment 39 sangu 2004-04-03 17:03:50 UTC
The same
problem (AA font, icon and mouse cursor are crushed) happens in fedora
development  kernel-2.6.4-1.303, kernel-2.6.4-1.305.i686.rpm

Comment 40 sangu 2004-04-08 05:23:01 UTC
Created attachment 99226 [details]
XFree86.0.log in Kernel-2.6.5-1.308

This problem is fixed in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.5-1.308.i686.rpm.

uname -a
Linux boys 2.6.5-1.308 #1 Wed Apr 7 12:36:14 EDT 2004 i686 i686 i386 GNU/Linux

xorg-x11 version is xorg-x11-0.6.6-0.2004_03_30.5.

Comment 41 sangu 2004-04-09 15:33:26 UTC
Created attachment 99275 [details]
XFree86.0.log in kernel-2.6.5-1.314

The same
problem (AA font, icon and mouse cursor are crushed) happens again in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.5-1.314.i686.rpm

Comment 42 Arjan van de Ven 2004-04-09 16:22:30 UTC
ok so we have a case where we know that a feature breaks vesa
framebuffer; but we don't know how to fix it quite yet.
At least we know where to look now...

Comment 43 Arjan van de Ven 2004-04-09 17:01:49 UTC
ok found one bug so far in this code; 315 will have a fix for that;
I'll keep looking around for a bit more first though

Comment 44 Arjan van de Ven 2004-04-09 20:04:39 UTC
uploading 315 right now

Comment 45 sangu 2004-04-10 01:22:04 UTC
Created attachment 99293 [details]
XFree86.0.log in kernel-2.6.5-1.315

The same
problem (AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.5-1.315.i686.rpm

Comment 46 Arjan van de Ven 2004-04-10 09:13:00 UTC
hrmpf.

ok can you give the i586 kernel there a shot?
If that works well then I can rule out yet another thing ...

(unfortionately I don't have s3 savage hardware so can't reproduce this)

Comment 47 sangu 2004-04-10 11:06:44 UTC
Created attachment 99295 [details]
XFree86.0.log in kernel-2.6.5-1.315.i586

#rpm -q --queryformat '%{NAME} %{VERSION} %{ARCH}\n' kernel-2.6.5-1.315
kernel 2.6.5 i586

This problme doesn't happen in kernel-2.6.5-1.315.i586.rpm.

xorg-x11 works well. Your comments is right.

Comment 48 sangu 2004-04-12 13:15:29 UTC
The same
problem (AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.5-1.318.i686.rpm

Comment 49 sangu 2004-04-13 00:51:39 UTC
The same
problem (AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-2.6.5-1.319.i686.rpm

Comment 50 sangu 2004-04-13 13:55:52 UTC
The same
problem (AA font, icon and mouse cursor are crushed) happens in
http://people.redhat.com/arjanv/2.6/RPMS.kernel/kernel-smp-2.6.5-1.321.i686.rpm

Comment 51 Arjan van de Ven 2004-05-01 17:39:30 UTC
good news guys; we located a savage card and could reproduce this
issue. It'll be fixed in the next build which I'll throw at the RH
buildsystem in a few minutes and upload to people.redhat.com/arjanv/2.6 
will probably be build 347

Comment 52 sangu 2004-05-02 14:44:17 UTC
Your commnet is right. This problem is fiexed.


Note You need to log in before you can comment on or make changes to this bug.