Bug 110460 - Gnome Weather can't do metric
Summary: Gnome Weather can't do metric
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-19 18:34 UTC by Michael Soulier
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 13:11:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Soulier 2003-11-19 18:34:02 UTC
At the moment, the weather in Ottawa on weather.com shows up as 59F.

http://www.weather.com/outlook/travel/local/CAXX0343?from=search_city

[msoulier@biryani msoulier]$ units
2084 units, 71 prefixes, 32 nonlinear units
                                                                     
            
You have: tempF(59)
You want: tempC
        15

+15C. 

Asking the weather applet, it says it's -17C in Ottawa. Just a tad
off. ;-)

If however, I switch to Fahrenhiet, it says +59F. 

Umm, subtract 32, divide by 1.8. ;-)

(59 - 32) / 1.8
15

I think there's a small arithmetic error in that applet. 

Cheers.

Comment 1 Michael Soulier 2003-11-19 18:35:18 UTC
Oh, that's interesting. I just switched it out of metric, and back in,
and now it says +15. Looks like some kind of initialization problem then. 

Comment 2 Mark McLoughlin 2004-07-19 08:55:09 UTC
Yeah, I've seen random problems with it too in the past. I suspect
things are a bit better now, though. If you can narrow it down to a
well reproducible scenario in Fedora Core 2 please re-open with the
details. Thanks ...

Comment 3 Mark McLoughlin 2004-12-20 13:11:17 UTC
No response, closing


Note You need to log in before you can comment on or make changes to this bug.