Bug 110462 - ide-scsi not compiled since 2.6.0-0.test9.1.89 [CONFIG_BLK_DEV_IDESCSI]
ide-scsi not compiled since 2.6.0-0.test9.1.89 [CONFIG_BLK_DEV_IDESCSI]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://people.redhat.com/arjanv/2.5/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 13:44 EST by Hans Ecke
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/bin/dmesg output for 2.6.0-0.test9.1.93 kernel (39 bytes, text/plain)
2003-11-22 15:51 EST, Hans Ecke
no flags Details
all the syslog/klog output when booting 2.6.0-0.test9.1.93 (23.45 KB, text/plain)
2003-11-22 15:57 EST, Hans Ecke
no flags Details
/bin/dmesg output for 2.6.0-0.test9.1.93 kernel (8.33 KB, text/plain)
2003-11-22 16:02 EST, Hans Ecke
no flags Details

  None (edit)
Description Hans Ecke 2003-11-19 13:44:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
kernel-2.6.0-0.test9.1.70 contained the ide-scsi modules.
kernel-2.6.0-0.test9.1.89 does not contain it anymore. This disables
some devices that need IDE-SCSI emulation.



Version-Release number of selected component (if applicable):
2.6.0-0.test9.1.89

How reproducible:
Always

Steps to Reproduce:
1.Have a system that uses IDE-SCSI
2.Boot into 2.6.0-0.test9.1.89
3.Try to access the IDE_SCSI device
    

Actual Results:  Can't access the device

Expected Results:  Device works

Additional info:

Here is part of the difference in kernel config:
/boot> diff -dubBw config-2.6.0-0.test9.1.70 config-2.6.0-0.test9.1.89
--- config-2.6.0-0.test9.1.70   2003-11-05 08:36:02.000000000 -0700
+++ config-2.6.0-0.test9.1.89   2003-11-17 02:19:55.000000000 -0700
@@ -372,7 +382,7 @@
 CONFIG_BLK_DEV_IDECD=m
 CONFIG_BLK_DEV_IDETAPE=m
 CONFIG_BLK_DEV_IDEFLOPPY=y
-CONFIG_BLK_DEV_IDESCSI=m
+# CONFIG_BLK_DEV_IDESCSI is not set
 # CONFIG_IDE_TASK_IOCTL is not set
 # CONFIG_IDE_TASKFILE_IO is not set

@@ -389,7 +399,6 @@

> uname -r
2.6.0-0.test9.1.89
> cdrecord -scanbus
Cdrecord 2.01a16 (i686-pc-linux-gnu) Copyright (C) 1995-2003 J�rg
Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot
open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you
are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
Comment 1 Arjan van de Ven 2003-11-19 13:48:35 EST
this is deliberate......

cdrecord --dev=/dev/hdc

is the new way to do this in 2.6...
Comment 2 Hans Ecke 2003-11-19 14:17:39 EST
This does not work for me: 
 
> cdrecord --dev=/dev/hdc -data -v n18n.iso 
Cdrecord-Clone 2.01a19 (i686-redhat-linux-gnu) Copyright (C) 
1995-2003 Jörg Schilling 
TOC Type: 1 = CD-ROM 
scsidev: '/dev/hdc' 
devname: '/dev/hdc' 
scsibus: -2 target: -2 lun: -2 
Warning: Open by 'devname' is unintentional and not supported. 
Linux sg driver version: 3.5.27 
Using libscg version 'schily-0.7' 
cdrecord: Warning: using inofficial libscg transport code version 
(schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c  1.75 
02/10/21 Copyright 1997 J. Schilling'). 
SCSI buffer size: 64512 
atapi: 1 
cdrecord: Cannot do inquiry for CD/DVD-Recorder. 
cdrecord: Success. test unit ready: scsi sendcmd: no error 
CDB:  00 00 00 00 00 00 
status: 0x2 (CHECK CONDITION) 
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 20 00 00 00 
Sense Key: 0x5 Illegal Request, Segment 0 
Sense Code: 0x20 Qual 0x00 (invalid command operation code) Fru 0x0 
Sense flags: Blk 0 (not valid) 
cmd finished after 0.000s timeout 40s 
cdrecord: The unit seems to be hung and needs power cycling. 
 
It can see it though: 
 
> cdrecord --dev=/dev/hdc -scanbus 
Cdrecord-Clone 2.01a19 (i686-redhat-linux-gnu) Copyright (C) 
1995-2003 Jörg Schilling 
scsidev: '/dev/hdc' 
devname: '/dev/hdc' 
scsibus: -2 target: -2 lun: -2 
Warning: Open by 'devname' is unintentional and not supported. 
Linux sg driver version: 3.5.27 
Using libscg version 'schily-0.7' 
cdrecord: Warning: using inofficial libscg transport code version 
(schily - Red Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c  1.75 
02/10/21 Copyright 1997 J. Schilling'). 
scsibus0: 
        0,0,0     0) '' '' '' NON CCS Disk 
        0,1,0     1) * 
        0,2,0     2) * 
        0,3,0     3) * 
        0,4,0     4) * 
        0,5,0     5) * 
        0,6,0     6) * 
        0,7,0     7) * 
 
 
Comment 3 Dave Jones 2003-11-21 13:32:34 EST
can you attach the dmesg output of this box ?
Comment 4 Hans Ecke 2003-11-22 15:51:33 EST
Created attachment 96135 [details]
/bin/dmesg output for 2.6.0-0.test9.1.93 kernel
Comment 5 Hans Ecke 2003-11-22 15:57:24 EST
Created attachment 96136 [details]
all the syslog/klog output when booting 2.6.0-0.test9.1.93

The only real difference between the 'dmesg' output and this is the smartd[]
section (after line 189) and "modprobe: FATAL: Module char_major_xxx not found"
section after line 209.
Comment 6 Hans Ecke 2003-11-22 16:02:49 EST
Created attachment 96137 [details]
/bin/dmesg output for 2.6.0-0.test9.1.93 kernel

Hm, the last attachment of this didn't work, lets try again.
Comment 7 Dave Jones 2003-11-24 09:44:50 EST
modprobe ide-cd
Comment 8 Hans Ecke 2003-11-24 13:46:25 EST
Thank you very much, that fixes it. 
 
Why doesn't the system know this by itself? In other words, what do I 
put in my /etc/modprobe.conf or the kernel command line to make this 
automatic? 
 
On a related note, since a few of Arjan's releases, the system does 
not know to 'modprobe' the sound modules either. I need to start them 
explicitly with "modprobe snd;modprobe sound-slot-0". Is this a 
problem, should I file another bug for this or is it my stupidity? 

Note You need to log in before you can comment on or make changes to this bug.