Bug 110464 - ATI Graphics Pro Turbo PCI Mach64 video card won't display > 256 colors in XFree86
ATI Graphics Pro Turbo PCI Mach64 video card won't display > 256 colors in XF...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 13:56 EST by David A. Smith
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-22 10:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log file of the results from trying to display more than 256 colors. (15.93 KB, text/plain)
2003-11-19 14:09 EST, David A. Smith
no flags Details
XF86Config file configured for the ATI Graphics Pro Turbo PCI Card (6.26 KB, text/plain)
2003-11-19 14:25 EST, David A. Smith
no flags Details

  None (edit)
Description David A. Smith 2003-11-19 13:56:25 EST
Description of problem:

When setting up XFree86 to work with an ATI Graphics Pro Turbo PCI
videio card equip with 4 MB of VRAM, XFree86 will detect the video
card and the 4 MB of VRAM but will refuse to display more than 256
(8-bit) colors in any resolution mode of the Graphics Pro Turbo PCI card.

Version-Release number of selected component (if applicable):

XFree86-4.2.1-21

How reproducible:

Configure XFree86 for the ATI Graphics Pro Turbo PCI card.

What ever happen to the XConfigurator utility program?

Steps to Reproduce:
1.
2.
3.
  
Actual results:

XFree86 will detect the ATI Mach64 chipset and 4 MB of VRAM on the
Graphics Pro Turbo PCI card but will refuse to use more than 256
(8-bit) colors in any valid graphics resolution mode. This works fine
in RedHat Linux 7.2 and previous releases that I have used.

Expected results:

XFree86 should detect the ATI Graphics Pro Turbo PCI card with 4 MB of
VRAM and display more than 256 (8-bit) color, such as full 24-bit
color depending on the valid graphics resolution modes.

Additional info:
Comment 1 David A. Smith 2003-11-19 14:09:12 EST
Created attachment 96066 [details]
XFree86.0.log file of the results from trying to display more than 256 colors.
Comment 2 David A. Smith 2003-11-19 14:25:38 EST
Created attachment 96068 [details]
XF86Config file configured for the ATI Graphics Pro Turbo PCI Card

This XF86Config file is setup for an ATI Graphics Pro Turbo PCI card with the
extra 2 MB VRAM option added giving it a total of 4 MB VRAM. Also, I am using
an IBM P200 SVGA monitor, which the listed graphics resolution modes should be
valid with since they were working fine with RedHat Linux 7.2 XFree86.
Comment 3 Mike A. Harris 2004-01-22 10:36:26 EST
This isn't a bug, but rather it is a misconfiguration.  The X server
log file shows the following:

(**) ATI(0): Depth 16, (--) framebuffer bpp 16
(EE) ATI(0): Depth 16 is not supported through this adapter.

This declares that depth 16 is not supported by the video driver
for this particular adaptor.  Looking through previous driver
releases in older XFree86 releases, this particular adaptor has
never had 16 bit depth support in XFree86 4.x.  If you had this
card working in 16 bit depth in Red Hat Linux 7.2, then you almost
certainly must have been using one of the no longer supported
XFree86 3.3.6 X servers (we stopped shipping them in 8.0), or the
'vesa' driver.

Here are a few workarounds/alternative solutions that may or may
not be useful:

- Try using the unsupported 'vesa' driver.  If this works, it will
  give unsupported unaccelerated 16bit depth perhaps.

- Try using kernel framebuffer driver, also unsupported.  You can
  use the Framebuffer-HOWTO for tips on how to set this up.

- If you're the adventurous-developer type, you might want to take
  a stab at porting the 16 bit depth support in 3.3.6 (assuming it
  supported 16bit on this card), and port it to CVS head ati driver,
  then submit that to XFree86.org for inclusion in 4.5.0.

- Alternatively, you may wish to file a request for enhancement to
  XFree86.org via http://bugs.xfree86.org bugzilla.

- Post a message to xfree86@xfree86.org user help forum, and perhaps
  another user/developer may have other suggestions that are
  worthwhile exploring.

Hope this helps.

Closing as 'NOTABUG'.

Note You need to log in before you can comment on or make changes to this bug.