Bug 110469 - Finish button not correctly enabled when converting projects to C/C++ natures
Finish button not correctly enabled when converting projects to C/C++ natures
Status: CLOSED UPSTREAM
Product: Red Hat Developer Suite
Classification: Retired
Component: CDT (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 14:49 EST by Jeremy Handcock
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 16:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Handcock 2003-11-19 14:49:14 EST
Description of problem:
When converting a project to C/C++, the "Finish" button is not
initially enabled in the "Candidates for conversion" dialog, even
though a checkbox in the list is checked.  

Version-Release number of selected component (if applicable):
snapshot-20031119-eclipse-2.1.1-3

How reproducible:
Always

Steps to Reproduce:
1. Right-click on project to be converted: New -> Other...
2. Select "C" (or "C++") and "Convert to a C/C++ Make Project"
3. Click Next

Actual Results:  The project that I selected to convert has its
checkbox checked, but the Finish button is not enabled.

Expected Results:  The Finish button should be enabled whenever a
checkbox is checked.
Comment 1 Tom Tromey 2003-11-19 15:28:33 EST
I've investigated this a little.
If you click on the project's name, the Finish button
will be enabled.  So, that's a workaround.
Comment 2 Tom Tromey 2003-11-20 13:49:28 EST
I researched this some more.
It appears to be a bug either in SWT or in Gtk.
It looks like the CDT code is implemented properly...

When creating the CheckboxTableViewer, the CDT code calls
setAllChecked(false) to clear all the items.  If you examine
the checked items immediately after this, none are checked.

So, at this point it looks like a rendering problem of some kind:
the item really isn't checked, and is simply displayed incorrectly.

I'm going to stop work on this PR for the time being.  It isn't
critical enough to justify the time I've already put in...
We can look again later.
Comment 3 Ben Konrath 2004-11-29 16:30:13 EST
This works in CDT 2.0 (tested with eclipse-cdt-2.0.2-1 rpm).

Note You need to log in before you can comment on or make changes to this bug.