Bug 110472 - CDT parser aborts when editing simple source file
CDT parser aborts when editing simple source file
Status: CLOSED WONTFIX
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Handcock
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 15:10 EST by Jeremy Handcock
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 11:34:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Handcock 2003-11-19 15:10:28 EST
Description of problem:
I was editing a Hello World program using the CDT editor, and the
parser threw up on more than one occasion.

Version-Release number of selected component (if applicable):
snapshot-20031119-eclipse-2.1.1-3


How reproducible: Sometimes

Steps to Reproduce:
1. Edit a source file with the CDT editor
2.
3.
  
Actual results: I get things like the following printed on the console
where I started eclipse:

[snip]
Parse Aborted: Encountered "<EOF>" at line 63, column 8.
Was expecting:
    <CloseQuote2> ...

        Parse Aborted: Encountered "<EOF>" at line 250, column 3.
        Was expecting one of:
            <ArgName> ...
                <TagEnd> ...

                    Parse Aborted: Encountered "<EOF>" at line 492,
column 20.
                    Was expecting:
                        <CloseQuote2> ...
[/snip]

... which is odd, becuase my source file is not 492 lines long.  I
will investigate this further and move the PR upstream.
Comment 1 Tom Tromey 2003-11-21 12:10:27 EST
Jeremy, I'm assigning these to you for triage, since you said
on the list you'd be looking at them.
Comment 2 Jeremy Handcock 2003-12-17 11:34:28 EST
After examining the upstream bugs against the CDT parser, I've decided
to close this here.  There are still numerous problems with the 1.2
parser and NPEs in the parser code are not uncommon.  Until the parser
is stabilized upstream, we will continue to have sporadic problems
like this.

Note You need to log in before you can comment on or make changes to this bug.