Bug 110479 - Creating new OProfile launch configuration fails (NPE)
Summary: Creating new OProfile launch configuration fails (NPE)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Keith Seitz
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-19 22:02 UTC by Jeremy Handcock
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-20 00:36:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.log trace (7.42 KB, text/plain)
2003-11-19 22:05 UTC, Jeremy Handcock
no flags Details

Description Jeremy Handcock 2003-11-19 22:02:01 UTC
Description of problem:
A NPE occurs when creating a "Profile C/C++ Application" launch
configuration, and the launcher cannot continue.

Version-Release number of selected component (if applicable):
snapshot-20031119-eclipse-2.1.1-3


How reproducible: Always


Steps to Reproduce:
1. Create a "Profile C/C++ Application" launch configuration (Run ->
Run..., select Profile C/C++ Application, click New)
2. Enter root password

Will attach .log trace.

Comment 1 Jeremy Handcock 2003-11-19 22:05:42 UTC
Created attachment 96070 [details]
.log trace

Comment 2 Keith Seitz 2003-11-20 00:36:52 UTC
Ok, I finally figured it out... Topanaga is running a kernel which
does NOT support Oprofile.

If you try to initialize oprofile from the command line, you see:
-bash-2.05b$
/usr/lib/eclipse/plugins/com.redhat.eclipse.oprofile.core.linux_1.0.0/opcontrol-wrapper
--init
You are attempting to run "opcontrol-wrapper" which requires
administrative
privileges, but more information is needed in order to do so.
Password for root:
modprobe: Can't locate module oprofile
modprobe: Can't locate module oprofile
Kernel doesn't support oprofile
-bash-2.05b$ rpm -q oprofile
oprofile-0.5.4-13
-bash-2.05b$ grep OPROFILE /boot/config-2.4.21-4.EL
# CONFIG_OPROFILE is not set
# CONFIG_OPROFILE is not set
# CONFIG_OPROFILE is not set

No oprofile kernel!

Clearly, I've neglected to add warnings and error handling for the
case where oprofile does not initialize.

I don't see this because my machine is SMP, and oprofile is compiled
as a module for the SMP kernel. I will investigate what the proper
course of action is (it could be as simple as rebuilding kernel
w/oprofile).

I just pray that single-CPU systems need to use the RTC...


Comment 3 Keith Seitz 2003-11-20 15:48:45 UTC
According to oprofile and kernel folk, you must run the SMP kernel to
use oprofile. "Official" explanation:

On Wed, Nov 12, 2003 at 09:22:00PM +0100, John Hearns wrote:

Hi John,

 > I note though that the oprofile module is built into
 > the 2.4.22-1.2115.nptlsmp kernel only - the uniprocessor one
 > hasn't got it. Anyone know why? Not looking to point fingers,
 > just curious as there might be an interesting reason.

historical reasons. Enabling UP-APIC has caused problems for
many systems in the past. Maybe for FC2 we can run a beta with
it on, and DMI blacklist any bad eggs, and see how far that
gets us.

FWIW, I miss oprofile on UP too 8-)

		Dave






Note You need to log in before you can comment on or make changes to this bug.