Bug 110482 - php-4.3.3-6.src.rpm with oci8 build errors
php-4.3.3-6.src.rpm with oci8 build errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 113189 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 17:20 EST by Richard D. Hamblett
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.3.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-18 06:18:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for mysql and oracle (1.14 KB, patch)
2003-11-28 09:44 EST, Jan Visser
no flags Details | Diff

  None (edit)
Description Richard D. Hamblett 2003-11-19 17:20:40 EST
Description of problem:
When building php-4.3.3-6 from src.rpm with --define 'oracle 1' the 
files lists and stub .ini files for the oci8 subpackage are not
generated and the build stops with errors.  When I changed
"%{!?oracle:oci8}", in line 397 of the php.spec file, to "oci8" the
build worked OK.  I don't know enough sh scipting to fix it properly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jan Visser 2003-11-28 09:44:46 EST
Created attachment 96237 [details]
fix for mysql and oracle 

This patch should fix the problem with files.mssql and files.oci8 not being
generated
Comment 2 Joe Orton 2003-11-28 09:56:18 EST
Thanks for looking into this.  It looks like a simpler fix is to change:

%{!?oracle:oci8} %{!?mssql:mssql}

to

%{?oracle:oci8} %{?mssql:mssql}
Comment 3 Joe Orton 2003-12-01 06:23:46 EST
I've integrated that change for 4.3.4-2 in Raw Hide, can you try it
out when it's available?
Comment 4 Joe Orton 2003-12-18 06:18:23 EST
Please reopen if there are furhter problems with 4.3.4-2 or later. 
Thanks for the report and patch.
Comment 5 Joe Orton 2004-01-09 09:53:02 EST
*** Bug 113189 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.