This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 110543 - regression: kernel fails to detect ICH5 SATA controller
regression: kernel fails to detect ICH5 SATA controller
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-20 18:54 EST by Kaj J. Niemi
Modified: 2013-07-02 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 03:22:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of lspci while running 2.4.20-20.9 (637 bytes, text/plain)
2003-11-20 18:55 EST, Kaj J. Niemi
no flags Details
Output of lspci -vvv under 2.4.20-20.9 (4.42 KB, text/plain)
2003-11-20 18:56 EST, Kaj J. Niemi
no flags Details
dmesg output under 2.4.20-20.9 (11.78 KB, text/plain)
2003-11-20 18:57 EST, Kaj J. Niemi
no flags Details
Output of lspci while running 2.4.22-1.2115.nptlsmp (637 bytes, text/plain)
2003-11-20 19:07 EST, Kaj J. Niemi
no flags Details
Output of lspci -vvv while running 2.4.22-1.2115.nptlsmp (4.04 KB, text/plain)
2003-11-20 19:08 EST, Kaj J. Niemi
no flags Details
Output of dmesg while running 2.4.22-1.2115.nptlsmp (ICH5 lines missing) (11.10 KB, text/plain)
2003-11-20 19:10 EST, Kaj J. Niemi
no flags Details
dmesg while running 2.4.22-1.2138.nptlsmp (11.86 KB, text/plain)
2004-01-14 08:19 EST, Kaj J. Niemi
no flags Details

  None (edit)
Description Kaj J. Niemi 2003-11-20 18:54:35 EST
Description of problem:
rawhide kernel 2.4.22-1.2115.nptlsmp fails to detect ICH5 SATA
controller resulting in horrible performance.
2.4.21-20.1.2024.2.1.nptlsmp seems to exhibit the same behavior.. I
didn't have any interim 2.4.22-1.19xx/2xxx kernels anymore to try with.

Using an older RH9 kernel (2.4.20-20.9) works just fine.

Attached is lspci and dmesg while running under 2.4.20-20.9.

Version-Release number of selected component (if applicable):
2.4.22-1.2115.nptlsmp, 2.4.21-20.1.2024.2.1.nptlsmp, 2.4.20-20.9smp

How reproducible:
Always


Regression -> Severity: high
Comment 1 Kaj J. Niemi 2003-11-20 18:55:31 EST
Created attachment 96106 [details]
Output of lspci while running 2.4.20-20.9
Comment 2 Kaj J. Niemi 2003-11-20 18:56:15 EST
Created attachment 96107 [details]
Output of lspci -vvv under 2.4.20-20.9
Comment 3 Kaj J. Niemi 2003-11-20 18:57:19 EST
Created attachment 96108 [details]
dmesg output under 2.4.20-20.9
Comment 4 Kaj J. Niemi 2003-11-20 19:07:21 EST
Created attachment 96109 [details]
Output of lspci while running 2.4.22-1.2115.nptlsmp
Comment 5 Kaj J. Niemi 2003-11-20 19:08:33 EST
Created attachment 96110 [details]
Output of lspci -vvv while running 2.4.22-1.2115.nptlsmp
Comment 6 Kaj J. Niemi 2003-11-20 19:10:52 EST
Created attachment 96111 [details]
Output of dmesg while running 2.4.22-1.2115.nptlsmp (ICH5 lines missing)
Comment 7 Kaj J. Niemi 2003-11-21 09:36:09 EST
Hmmm might the problem be related to the fact that in 2.4.22 SATA is
part of the ata_piix module (drivers/ide/pci/pci.c, line 880)
while in 2.4.20 they're still part of the kernel?

Attempting to modprobe ata_piix locks the system up. ;-)

Comment 8 Kaj J. Niemi 2003-12-16 15:47:44 EST
The problem is still there with 2.4.22-1.2135.nptlsmp
Comment 9 Jeff Garzik 2004-01-12 13:55:55 EST
You need to set your BIOS to enhanced mode, before loading ata_piix
driver.  Does that solve the lockups?
Comment 10 Kaj J. Niemi 2004-01-14 08:19:15 EST
Created attachment 96968 [details]
dmesg while running 2.4.22-1.2138.nptlsmp

Jeff,

Yes and no. ;-) I had time to kick around with this particular problem so
here's what I found out when installing from scratch:

When kickstaring FC1 installations (kernel-2.4.20-1.2115) in enhanced mode the
first thing happening is that anaconda attempts to load ata_piix and the system
freezes.

Changing to AUTO mode (I guess this becomes combined?) loads the ata_piix
module, the drive shows up as /dev/sda and the installation succeeds.
Read/write speeds are also satisfactory

After installation if I change from auto/combined to enhanced mode everything
works and there are no lockups.

I'll wait for FC2 betas, try installing in enhanced mode and see what happens.

Note You need to log in before you can comment on or make changes to this bug.