Bug 110549 - installing many packages results in a lot of disc swapping
installing many packages results in a lot of disc swapping
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-20 19:42 EST by Philip Mitchell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Mitchell 2003-11-20 19:42:14 EST
Description of problem:
If I select a bunch of packages to install from redhat-config-packages
which are located on different discs there is a lot of disc-swapping
required.

Obviously there has to be some swapping, but if I have to insert 2
discs 5 times each, that's completely unneccesary.

Also, the button with focus by default is Cancel on the "Isert Disc"
dialog, which could lead to accidental cancellation -- better to have
the default be OK as this will only result in a return of the dialog

Version-Release number of selected component (if applicable):
Fedora Core v1.0
redhat-config-packages v1.2.7-1

How reproducible:
always

Steps to Reproduce:
1. Do a basic install (just X windows and required components)
2. Run redhat-config-packages 1.2.7-1
3. Select several packages from different categories
4. click Update
  
Actual results:
"Insert Disc 1" then "Insert Disc 2" then "Insert Disc 3" then "Insert
Disc 1", "Insert Disc 2", disc 1, disc 2, disc 1, disc 3, disc 1, disc
2, etc...
Button with focus on the prompt screens is Cancel

Expected results:
Should be prompted to insert each disc only once (if it is required).
 Default button on prompt should be OK

Additional info:
This may be a minor concern to some, but to a regular user who doesn't
like to swap cds all the time, this is a real problem.  This brings
back memories of floppy disks.
Comment 1 Jeremy Katz 2003-11-21 16:20:35 EST
Unfortunately, the ordering is provided by rpm and getting something
"better" is hard :/
Comment 2 Jeremy Katz 2005-09-21 16:19:09 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.