Bug 110552 - mod_proxy breaks windowsupdate.microsoft.com
mod_proxy breaks windowsupdate.microsoft.com
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-20 20:23 EST by Brian Baggett
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 11:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Baggett 2003-11-20 20:23:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20031007

Description of problem:
This is the httpd bug from
http://issues.apache.org/bugzilla/show_bug.cgi?id=21348

"Apache2 proxy seems to drop Content-Length header from replies to
HEAD requests. This is very bad for Microsoft's Windows Update system
(and against HTTP spec). The problem is caused by CONTENT_LENGTH
output filter setting Content-Length header to zero because there is
no body data. Later on Apache removes Content-Length header if it has
value 0. The attached patch fixes the problem in CONTENT_LENGTH output
filter by preventing it from modifying the content length of a reply
to HEAD request. The attached patch is against HEAD of
APACHE_2_0_BRANCH as of this morning."

URL: http://www.mail-archive.com/dev@httpd.apache.org/msg16088.html
Patch:
http://www.mail-archive.com/dev@httpd.apache.org/msg16088/windows-update.diff

I backported the patch listed in the diff as a part of my own RPM and
rebuilt it.  It works as expected then.

Version-Release number of selected component (if applicable):
httpd-2.0.47-10

How reproducible:
Always

Steps to Reproduce:
Load up httpd with the proxy enabled.  Go to
Windowsupdate.microsoft.com.  Watch it error out with error
#0x80072f76.  Rebuild with the above patch and it will work fine.
    

Additional info:
Comment 1 Joe Orton 2003-11-21 03:49:25 EST
This should be fixed in 2.0.48 - can you try the 2.0.48 updates?

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/1/i386/

Comment 2 Brian Baggett 2003-11-21 09:19:34 EST
I first pulled the httpd-2.0.48-1.2 RPM from
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/1/i386/
and tried it unpatched and it doesn't work.  When that happened, I got
the SRPM and the patch I referenced from CVS did not make it in to
protocol.c.  After adding it, it worked just like 2.0.47 did.  But
2.0.48 is still broken in this regard by default.
Comment 3 Matthew Miller 2006-07-11 13:21:30 EDT
Fedora Core 1 is maintained by the Fedora Legacy project for security updates
only. If this problem is a security issue, please reopen and reassign to the
Fedora Legacy product. If it is not a security issue and hasn't been resolved in
the current FC5 updates or in the FC6 test release, reopen and change the
version to match.

Thanks!

NOTE: Fedora Core 1 is reaching the final end of support even by the Legacy
project. After Fedora Core 6 Test 2 is released (currently scheduled for July
26th), there will be no more security updates for FC1. Please use these next two
weeks to upgrade any remaining FC1 systems to a current release.

Comment 4 John Thacker 2006-10-28 11:04:09 EDT
Closing per lack of response to the previous comment.  Note that FC1 and FC2 are
no longer supported even by Fedora Legacy.  If this bug still occurs on FC3 or
FC4, please assign to that version and Fedora Legacy.  If it still occurs on FC5
or FC6, please reopen and assign to the correct version.

Note You need to log in before you can comment on or make changes to this bug.