Bug 11062 - Interface independant static routes fail in /etc/rc.d/init.d/network
Interface independant static routes fail in /etc/rc.d/init.d/network
Status: CLOSED DUPLICATE of bug 11591
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-26 21:14 EDT by horms
Modified: 2014-03-16 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-26 08:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description horms 2000-04-26 21:14:01 EDT
/etc/rc.d/init.d/network shipped in initscripts has a bug that prevents the
addition of interface indpendant static routes in
/etc/sysconfig/static-routesfrom working.

Here is a patch, the problem would apear to be a typo.

--- /etc/rc.d/init.d/network    Wed Apr 26 18:00:11 2000
+++ /etc/rc.d/init.d/network.orig       Wed Apr 26 17:59:44 2000
@@ -69,7 +69,7 @@
        # Add non interface-specific
static-routes.
        if [ -f /etc/sysconfig/static-routes ]; then
           grep "^any" /etc/sysconfig/static-routes | while read ignore
type
+dest netmask mask gw gateway; do
-             [ "${gateway}" != "${gateway##[0-9]}" ] && \
+             [ "${gateway}" != "${gateway##[0-9}" ] && \
                /sbin/route add -$type $dest $netmask $mask $gw $gateway
           done
        fi
Comment 1 horms 2000-04-26 21:21:59 EDT
Apologies, the patch seems to be reversed.
Comment 2 Michael Tokarev 2000-05-26 08:18:59 EDT
The same again. See bug id 11603
(http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=11603)
and my comments to bug id 11591
(http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=11591)
Comment 3 Bill Nottingham 2000-05-31 18:43:50 EDT

*** This bug has been marked as a duplicate of 11591 ***

Note You need to log in before you can comment on or make changes to this bug.