Bug 110667 - gimp-print spec file problem when not "build_with_ijs_support"
gimp-print spec file problem when not "build_with_ijs_support"
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gimp-print (Show other bugs)
3.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-22 11:51 EST by Jos Vos
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-22 14:34:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2003-11-22 11:51:37 EST
Description of problem:
When %build_with_ijs_support is set to 0 (for bootstrapping gimp-print
 for ghostscript), the build fails because of an unpackaged file
"ijsgimpprint.1", that seems to be generated anyway. So, the "%endif"
in the %files section of the spec file should be moved one line up.

Version-Release number of selected component (if applicable):
4.2.4-5
Comment 1 Tim Waugh 2003-11-22 14:26:33 EST
Works for me: this file is removed at the end of the %install section.
Comment 2 Jos Vos 2003-11-22 14:32:49 EST
Not in the 4.2.4-5 gimp-print.spec file as included in the RHEL 3
source rpm.  This is the %install section:

------------------------------------------------------------------
%install
rm -rf %{buildroot}
%makeinstall cups_prefix=%{buildroot}%{_prefix} \
        cups_exec_prefix=%{buildroot}%{_exec_prefix} \
        cups_bindir=%{buildroot}%{_bindir} \
        cups_conf_datadir=%{buildroot}%{_datadir}/cups \
        cups_conf_serverbin=%{buildroot}%{_libdir}/cups \
        cups_conf_serverroot=%{buildroot}%{_sysconfdir}/cups
for ver in %{_libdir}/gimp/*
do
  mkdir -p %{buildroot}$ver/plug-ins
  install -m0755 src/gimp/.libs/print %{buildroot}$ver/plug-ins/print
done

# Don't install this, since we don't list it in the manifest.
rm -f %{buildroot}%{_infodir}/dir

%find_lang %{name}
------------------------------------------------------------------


Comment 3 Tim Waugh 2003-11-22 14:34:24 EST
Ah.  Well, it's fixed in Fedora Core 1.

Note You need to log in before you can comment on or make changes to this bug.