Bug 110670 - redhat-config-* (python gui) crash at start and give python errors
redhat-config-* (python gui) crash at start and give python errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-22 12:44 EST by marc frei
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 10:27:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marc frei 2003-11-22 12:44:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
[root@tuxlaptop tmp]# redhat-config-network
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 68, in <lambda>
    PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 281,
in handleException
    rc = exceptionWindow (_("Exception Occurred"), text, progname)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 166,
in exceptionWindow
    win = ExceptionWindow (text, name)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 35,
in __init__
    win = gtk.Dialog(_("Exception Occurred"), None, gtk.DIALOG_MODAL)
AttributeError: 'module' object has no attribute 'Dialog'

Original exception was:
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 73, in ?
    import gtk
  File
"/usr/src/build/302542-i386/install/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.py",
line 43, in ?
ImportError: /usr/lib/libfontconfig.so.1: undefined symbol:
FT_Get_PS_Font_Info
[root@tuxlaptop tmp]# 


Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.install a "RedHat Linux"
2.upgrade to fedora core 1
3.launch the command : redhat-config-network
    

Actual Results:  The commands "redhat-config" (services, network, boot
etc...) do not work any more

Additional info:

This happen with ALL the "redhat-config" (python GUI)
Comment 1 Kai Thomsen 2003-11-23 10:04:16 EST
I've seen several mentions of this dynamic linker error by people who 
upgraded their machine(s) from Red Hat Linux.

$ nm -D -o /usr/lib/libfreetype.so.6 | grep FT_Get_PS_Font_Info
/usr/lib/libfreetype.so.6:00385810 T FT_Get_PS_Font_Info
$ rpm -qf /usr/lib/libfreetype.so.6
freetype-2.1.4-5
$

So in case that version of the FreeType package is installed, this 
error has to be due to an older library version in /usr/X11R6/lib or 
/usr/local/lib.  "ldd -d /usr/lib/libfontconfig.so.1 | grep freetype" 
should reveal it.
Comment 2 marc frei 2003-11-23 17:04:40 EST
Thanks Kai !!

removing : 

/usr/X11R6/lib/libfreetype.so.6.2

solved the problem for all my redhat-config-* tools.

Before removing, check :

rpm -qf /usr/X11R6/lib/libfreetype.so.6
file /usr/X11R6/lib/libfreetype.so.6 doesn't belong to any package.

So, OK to remove.

Comment 3 Harald Hoyer 2003-11-25 10:33:39 EST
reassigning
Comment 4 Harald Hoyer 2003-12-17 03:38:12 EST
reassigning
Comment 5 Owen Taylor 2003-12-17 10:27:01 EST
/usr/X11R6/lib/libfreetype.so.6 isn't coming from a Red Hat /
Fedora package, but probably from some manual install of
XFree86 or similar.

Note You need to log in before you can comment on or make changes to this bug.