Bug 110673 - Bad none .pls .m3u handling when saving playlists
Bad none .pls .m3u handling when saving playlists
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmms (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-22 18:11 EST by Philip Wyett
Modified: 2014-03-16 22:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.9-1.p
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 23:35:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix 'Unable to save playlist problem' (478 bytes, patch)
2003-11-22 21:48 EST, Philip Wyett
no flags Details | Diff

  None (edit)
Description Philip Wyett 2003-11-22 18:11:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When attempting to save a playlist and forget to select '.pls', '.m3u'
and leave 'Determine file type' as 'By extension' and not add a '.pls'
or '.m3u' extension xmms will just sit there and not save the file or
prompt you that their is a problem. If you look in the gnome panel it
tells you 'Unable to save playlist', but not on screen and the
playlist save dialog stops responding to mouse clicks until you goto
the gnome panel, right click and click close on 'Unable to save playlist'.

Version-Release number of selected component (if applicable):
xmms-1.2.8-3.p

How reproducible:
Always

Steps to Reproduce:
1. Start xmms and load up some songs
2. Right click in playlist window and then select 'Playlist -> Save list'
3. Leave on 'Determine file type' and enter filename 'my_playlist' and
click on 'Ok'
    

Actual Results:  A 'Unable to save playlist' is given in the gnome
panel, but not on screen and the playlist save dialog becomes
unresponsive to any mouse clicks until you right click on the 'Unable
to save playlist' and close it.

Expected Results:  I should be given the error dialog on
screen/desktop stating that the playlist could not be saved.

Additional info:
Comment 1 Philip Wyett 2003-11-22 21:47:24 EST
Oops my fault here. The actual problem is the 'Unable to save
playlist' dilaog is getting trapped behind the 'Save playlist' window
when the desktop is full. This is due to a bad call to
'gtk_window_set_transient_for()', where the args are the wrong way
round. A patch to fix the problem and set the parent and child windows
correctly and have the 'Unable to save playlist' dialog appear on top
is attached.
Comment 2 Philip Wyett 2003-11-22 21:48:27 EST
Created attachment 96140 [details]
Patch to fix 'Unable to save playlist problem'
Comment 3 Bill Nottingham 2003-11-23 23:14:46 EST
Havard: does the patch look ok to you?
Comment 4 Håvard Kvålen 2003-11-24 18:44:06 EST
Yes, it has been applied to our cvs tree.
Comment 5 Bill Nottingham 2004-01-28 23:35:56 EST
This should be fixed in 1.2.9-1.p.

Note You need to log in before you can comment on or make changes to this bug.