Bug 110675 - valid users = %S fails in samba-3.0.0-14.3E
valid users = %S fails in samba-3.0.0-14.3E
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2003-11-22 20:06 EST by Ian Laurie
Modified: 2014-08-31 19:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: samba-3.0.2-6.3E
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 04:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2003-11-22 20:06:49 EST
Description of problem:

The %S in [homes] doesn't work correctly as in the following
example:

[homes]
   comment = Home Directory on %L (%U)
   browseable = no
   writable = yes
   valid users = %S
   create mode = 0644
   directory mode = 0755
# If you want users samba doesn't recognize to be mapped to a guest user
;  map to guest = bad user

Although correct password and userid authentication works
overall and for other shares, attempting access to the user's home
directory results in Win2k asking for a name and password, and
once entered, they fail to work.  Above example has been in
operation under samba-2.2.8a-2 for ages without problems.


Version-Release number of selected component (if applicable):

samba-3.0.0-14.3E


How reproducible:

Always.


Steps to Reproduce:
1. Provide [homes] share as in example above.
2. Attempt to access it from Win2k.

  
Actual results:

Win2k requests for a user name and password.  When entered
they don't work anyway.

Expected results:

Win2k shouldn't ask for a user name and password when the
/etc/samba/smbpasswd file is set correctly.

Additional info:

A temporary workaround is to comment out the "valid users" line,
but only on a "trusted" LAN.

The Samba folks *might* have fixed this bug.  The following
is a snippet from their current release notes in the section
titled "Changes since 3.0.0".

5)  Fix for "valid users = %S" in [homes].  Fix read/write 
    list as well. 

That looks like it might be it to me.
Comment 1 Jay Fenlason 2004-01-17 00:03:09 EST
I've put RPMs of samba-3.0.2rc1 on 
http://people.redhat.com/fenlason/.samba .  Can you try them and see if 
they resolve your problem.  Note that these are un-qa'd packages of a 
release that is not intended for production use.  If they solve your 
problem, I will attempt to get samba-3.0.2 included in the next quarterly 
update of Red Hat Enterprise Linux 3. 
Comment 2 Ian Laurie 2004-01-17 22:55:32 EST
You have fixed the problem completely.

I'll use this version from this point onwards.  Thank you.
Comment 3 Geoff Warner 2004-01-21 21:46:57 EST
Hi - I've run into the same problem and solved it by building a redhat
rpm from the samba-3.0.1.tar.bz2 source (using the makerpms.sh script
under packaging/RedHat).  I removed all associated samba rpms from the
system and then installed the built rpm.  Are there any issues I
should be aware of under RHEL 3?  All appears to be well.

Thanks.
Comment 7 Tom Wood 2004-05-27 10:11:31 EDT
Problem still exists in 3.0.2-6.3E.  Somehow we've regressed...
Comment 8 Ian Laurie 2004-05-29 06:41:49 EDT
I've just verified that users have both visability & access only to
their designated shares; samba-3.0.2-6.3E seems to be working
correctly for me here with respect to the use of %S on share definitions.

Certainly I don't have the same bug as I did with samba-3.0.0-14.3E.

Note You need to log in before you can comment on or make changes to this bug.