Bug 110686 - PCMCIA card Ethernet connection broken
PCMCIA card Ethernet connection broken
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-23 07:54 EST by Joachim Frieben
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpt from /var/log/messages (3.46 KB, text/plain)
2003-12-18 13:05 EST, Dan O'Brien
no flags Details

  None (edit)
Description Joachim Frieben 2003-11-23 07:54:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
An Ethernet connection created on some IBM Thinkpad 600e equipped with
an INTEL PRO/100 PCMCIA (Cardbus II) network adapter does not work.
The connection turns active in the network utility, but a simple ping
command for a static connection between to nodes connected by means of
a crossover cable yields the following output:

[root@localhost]# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) from 192.168.0.2 : 56(84) bytes of data.
From 192.168.0.2 icmp_seq=1 Destination Host Unreachable
From 192.168.0.2 icmp_seq=2 Destination Host Unreachable
From 192.168.0.2 icmp_seq=3 Destination Host Unreachable

The same holds when the computer is booted in a DHCP environment for a
DHCP connection.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. Create a static network connection.
2. Activate network connection.
3. Try to ping another computer connected to the network.


Actual Results:  Network connection turns active, but no other node
can be reached.

Expected Results:  Other nodes should at least respond to a simple
ping command.

Additional info:

For the various setups, only a single network connection had been
created to circumvent possible aliasing problems.
The problem only shows up after a fresh install of FC1. I then had
tried an upgrade after installing RHL9 for which the network just
worked fine, and in the case of a mere upgrade, the network
connections remained functional!
I also copied NETWORK and BROADCAST entries present in the RHL9
generated "ifcfg-eth0" file to the FC1 generated ones (static
connection) where they were missing, but this modification did not
change anything either.
For a desktop PC equipped with an INTEL Pro/100 PCI adapter, no
corresponding misbehaviour has been observed.

I might have posted the bug report for "initscripts", but the exact
origin is unclear to me, so I chose this one.
Comment 1 Harald Hoyer 2003-11-25 10:35:13 EST
reassigning to initscripts
Comment 2 John A. Smolin 2003-11-29 21:42:45 EST
I have the same prlblem with a thinkpad 770X and an "IBM" Xircom
cardbus pcmcia ethernet card.  A workaround is to manually run 
service pcmcia restart
then the network come up and works ok.

I had this problem way back in RH6 or so and forget exactly what fixes
it on boot.  It went away in more recent versions of Redhat Linux.  It
worked in RH8.0, never tried it unther RH9.  It has reappeared as an
issue in Fedora Core 1.

I tried switched the order that pcmcia and network startup at boot
time.  This gets rid of an error message but fails to resolve the problem.
Comment 3 Joachim Frieben 2003-12-06 14:36:35 EST
In my case, manually restarting the PCMCIA service actually fixes the 
problem, too! Essentially a workaround, but for the time being 
ensuring a working network connection. Thanks!
Comment 4 Dan O'Brien 2003-12-18 13:05:56 EST
Created attachment 96616 [details]
excerpt from /var/log/messages
Comment 5 Dan O'Brien 2003-12-18 13:06:33 EST
My 3com card on my Compaq Presario 1692 has twice dropped out leaving
the system hung.  This has been since the last kernel (2129). 
Eventually I have to power cycle the laptop.  This laptop is up 24x7.
Attached are some items from the syslog.
Comment 6 Bill Nottingham 2004-01-29 11:29:03 EST
That message dump indicates a kernel driver bug.
Comment 7 P Fudd 2004-02-06 05:24:10 EST
I have a xircom ether/modem card, and it lives long enough to get an
address from dhcp, but after that it can only send, not receive.

The simplest solution I've found is 'cardctl eject; cardctl insert'.
Comment 8 Joachim Frieben 2004-05-03 14:41:27 EDT
I have just installed Fedora Core 2 Test 3. Here, everythings works
out of the box. So, at least, no issue anymore beyond Fedora Core 1.
Comment 9 David Lawrence 2004-09-29 15:43:19 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.