Bug 110699 - Install packages from isos stored on hard disk
Install packages from isos stored on hard disk
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-23 12:16 EST by Nikos Charonitakis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:20:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Charonitakis 2003-11-23 12:16:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Ask for alternative to install additional packages (after
installation) from iso images stored to hard disk.
Currently fedora asks to insert cdromX.
Also i ask for choice to install from other cdrom than /dev/cdrom
(a system usually have additional cdroms e.g. /mnt/cdrom1).

Version-Release number of selected component (if applicable):
1.2.7-1

How reproducible:
Always

Steps to Reproduce:
1.Use of redhat-config-packages
2.I realized that my main cdrom needs service
3.I realized also that afrer that is difficult to use this tool altough
i have alternative sources (hard disk and additional cdrom) 
    

Additional info:
Comment 1 Kenneth Peterson 2004-01-02 13:20:54 EST
Here is the work around I am using.
Log in as root.
I copied the ISO images from another linux box via my LAN to the new
fedora box. 
I created these directories on root. /iso /iso/rpm /cd1 /cd2 /cd3
I placed the ISO images in /iso. 
I mounted the images with these commands:
mount -o loop -t iso9660 /iso/yarrow-i386-disc1.iso  /cd1
mount -o loop -t iso9660 /iso/yarrow-i386-disc2.iso  /cd2
mount -o loop -t iso9660 /iso/yarrow-i386-disc3.iso  /cd3
Use Nautilus to browse to /cd1/Fedora/RPMS
Open a 2nd Nautilus and browse to /iso/rmp
From the edit menu on the Nautilus at /cd1/Fedora/RPMS choose select
all files.
Use the mouse to drag and drop the selection to the Nautilus at /iso/rmp
Use Nautilus to browse to /cd2/Fedora/RPMS
From the edit menu on the Nautilus at /cd2/Fedora/RPMS choose select
all files.
Use the mouse to drag and drop the selection to the Nautilus at /iso/rmp
There will be one duplicate file. When it asks about the duplicate
tell it to skip the file.
Use Nautilus to browse to /cd3/Fedora/RPMS
From the edit menu on the Nautilus at /cd3/Fedora/RPMS choose select
all files.
Use the mouse to drag and drop the selection to the Nautilus at /iso/rmp
There will be one duplicate file. When it asks about the duplicate
tell it to skip the file.

Now when you want to install a package use can use Nautilus to browse
to /iso/rmp and double click on any rpm you want to install.
Note: When Nautilus opens the package always hit the "Details" button.
If it shows more than one package then there are dependences. Write
down the names of any dependant packages and find them and double
click to install them first. If you don't then the package install
will stop after the first package and ask for a cd. The package
manager is too stupid to look in the same directory first for the rpm.
I may be able to get around that problem by adding ./ to the path once
I find where fedora is loading its path at startup.
Comment 2 Jeremy Katz 2005-09-21 16:20:25 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.