Bug 110740 - possible duff source code
possible duff source code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 07:41 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 5.17.4.8.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 05:38:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 07:41:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package dvd+rw-tools-5_13_4_7_4-1 from Fedora.

The compiler said

growisofs.c(1457): warning #187: use of "=" where "==" may have been 
intended

The source code is

    if (rpid == (pid_t)-1 || (rpid != pid && (errno=ECHILD)))

Suspect

    if (rpid == (pid_t)-1 || (rpid != pid && (errno == ECHILD)))

would be better code.



Version-Release number of selected component (if applicable):
dvd+rw-tools-5_13_4_7_4-1 

How reproducible:
Always

Steps to Reproduce:
1. by inspection of source code.
2.
3.
    

Additional info:

Note You need to log in before you can comment on or make changes to this bug.