Bug 1107647 - VNC client on Satellite 6 webUI only works with browser allowing insecure connections
Summary: VNC client on Satellite 6 webUI only works with browser allowing insecure con...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Dominic Cleal
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-10 11:47 UTC by Jan Hutař
Modified: 2019-09-26 13:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:20:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (58.19 KB, image/png)
2014-06-10 11:47 UTC, Jan Hutař
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 3601 0 Normal Closed Use secure websockets for console access 2021-01-14 21:13:27 UTC

Description Jan Hutař 2014-06-10 11:47:43 UTC
Created attachment 907179 [details]
screenshot

Description of problem:
VNC client on Satellite 6 webUI does not work and is misaligned.


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140605.0


How reproducible:
always


Steps to Reproduce:
1. Setup Satellite 6 to the state you can provision guests on local
   libvirt compute resource
2. Provision some guest using network install
3. Attempt to access console of the guest via Satellite 6 webUI
     Infrastructure -> Compute Resources -> <libvirt_compute_resource> ->
       -> Virtual Machines -> <your_machine> -> [Console]


Actual results:
VNC console is not displayed, it timeouts and containing box is not aligned correctly


Expected results:
VNC console is displayed, functional and containing box is aligned correctly

Comment 1 RHEL Program Management 2014-06-10 12:05:57 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ohad Levy 2014-06-17 15:09:57 UTC
is there an SElinux issue on the server? alternatively, is this a firefox settings issue (as described at http://theforeman.org/manuals/1.5/#7.1NoVNC )

Comment 4 Jan Hutař 2014-06-18 20:28:36 UTC
(In reply to Ohad Levy from comment #3)
> is there an SElinux issue on the server? alternatively, is this a firefox
> settings issue (as described at http://theforeman.org/manuals/1.5/#7.1NoVNC )

Err, you are right. This was problem on my side and disabling that secority check in my browser helped.

So if it is not possible to make it work without client side modifications (and possibly looking some security), to add hint to the page about this limitation?

Comment 5 Ohad Levy 2014-06-19 11:23:35 UTC
I hope that https://github.com/theforeman/foreman/pull/1024 will address the issue, requires further testing (my concern is about the cert used for the wss).

Comment 6 Bryan Kearney 2014-07-16 08:03:25 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/3601 has been closed
-------------
Ewoud Kohl van Wijngaarden
https://github.com/theforeman/foreman/pull/1024 already tested with VMware and VNC. Needs testing with SPICE.

Comment 9 Bryan Kearney 2014-09-11 12:20:21 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.