Bug 110777 - Bash using a lot of processing power
Summary: Bash using a lot of processing power
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bash   
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL: http://www.bpweb.net/top.gif
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 15:39 UTC by Nick Byng
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version: 2.05b-33
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-28 13:15:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nick Byng 2003-11-24 15:39:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
There seems to be a issue when we run bash scripts or type on the 
command line hat it uses a lot of processing power.

Version-Release number of selected component (if applicable):
2.4.21-4.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1. Run a bash script
2. or just hold down a key on the command line
3.
    

Actual Results:  The cpu usuage goes up to 100% and the load average 
increases

Expected Results:  The system should not use hardly any power for 
bash scripts when we type on the comand line.

Additional info:

Comment 1 Nick Byng 2003-11-24 15:40:07 UTC
sam@bpweb.net

Comment 3 Nick Byng 2003-11-25 15:41:21 UTC
We have changed our bash to version to bash-2.05-8 and this seems to 
sort the problem out. Although using your supplied bash with ES 3 we 
still have the problem and bash only acts normally using this older 
version.

Comment 4 Tim Waugh 2003-11-28 13:15:15 UTC
This has been fixed in the fedora/development package (bash-2.05b-33),
and will be included in a future release.

In the mean time, you can use 'export LANG=C' to work around the
problem if need be.


Note You need to log in before you can comment on or make changes to this bug.