This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 110779 - bad source code
bad source code
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libtiff (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 10:45 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 15:47:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 10:45:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package libtiff-3_5_7-14 from Fedora.

The compiler said

1.

../tools/tiffset.c:89: warning: too few arguments for format

The source code is

                fprintf( stderr, "Field name %s not recognised.\n" );

Looks like a missing field name for the %s specifier.

2.

../tools/tiffset.c:115: warning: too few arguments for format

Same problem as #1.

3.

../tools/tiffcp.c(98): remark #174: expression has no effect

The source code is

        if ((*imageSpec)[1] == '\0') *imageSpec == NULL;

Better source code might be

        if ((*imageSpec)[1] == '\0') *imageSpec = NULL;



Version-Release number of selected component (if applicable):
libtiff-3_5_7-14 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:

Note You need to log in before you can comment on or make changes to this bug.