Bug 110781 - bad source code
bad source code
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeprintui (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 10:48 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 11:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 10:48:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package libgnomeprintui-1_116_0-5 from Fedora.

The compiler said

1.

transport-selector.c(203): remark #1011: missing return statement at 
end of non-void function "gpa_transport_selector_construct"

The source code is

static gint
gpa_transport_selector_construct (GPAWidget *gpaw)
{
        GPATransportSelector *ts;

        ts = GPA_TRANSPORT_SELECTOR (gpaw);

        ts->printer = gpa_node_get_path_node (GNOME_PRINT_CONFIG_NODE 
(gpaw->config), "Printer");

        gpa_ts_rebuild_widget (ts);
}

Looks like a missing "return 0;" to me.



Version-Release number of selected component (if applicable):
libgnomeprintui-1_116_0-5 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 Owen Taylor 2004-08-03 11:48:33 EDT
Fixed in current versions, libgnomeprintui-2.0 is for all
practical purposes dead and won't be in FC3 at all.

Note You need to log in before you can comment on or make changes to this bug.