Bug 110784 - gnome-libs-devel should Requires: libpng10-devel
Summary: gnome-libs-devel should Requires: libpng10-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-libs   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 15:56 UTC by Maxim Dziumanenko
Modified: 2007-04-18 16:59 UTC (History)
2 users (show)

Fixed In Version: gnome-libs-1.4.1.2.90-44
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 17:03:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxim Dziumanenko 2003-11-24 15:56:40 UTC
Description of problem:
gnome-config --libs gtkxmhtml returns -lpng10, thus gnome-libs-devel
should Requires: libpng10-devel

Version-Release number of selected component (if applicable):
gnome-libs-1.4.1.2.90-35

How reproducible:
Always

Steps to Reproduce:
1.rpm -i gnome-libs-deve-1.4.1.2.90-35.i386.rpm
2.rpm -e libpng10-devel
3.rpmbuild --rebuild Gtk-Perl-0.7008-35.src.rpm (it requires
gnome-libs-devel, and doesn't directly require libpng10-devel)
4.Wait for build errors

Actual results:


Expected results:


Additional info:

Comment 1 Miloslav Trmac 2003-11-25 14:56:15 UTC
Triage->Easyfix

Comment 2 Warren Togami 2004-04-13 21:06:36 UTC
BR libtool gettext

blocked by build failure caused by gtk-doc

Comment 3 Miloslav Trmač 2004-10-13 17:03:06 UTC
Fixed in gnome-libs-1.4.1.2.90-44. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.