Bug 110788 - bad source code
Summary: bad source code
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kakasi   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
: 110789 110790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 16:01 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 2.3.4-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 10:57:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-11-24 16:01:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package kakasi-2_3_4-13 from Fedora.

The compiler said

1.

k2.c(157): warning #175: subscript out of range

The source code is

char buffer[k2rom_buflen];

/* more code */

buffer[k2rom_buflen] = '\0'; clen = k2rom_buflen;

Array limits in C are exclusive, not inclusive.

2. 

libk2.c(157): warning #175: subscript out of range

Same problem again.



Version-Release number of selected component (if applicable):
kakasi-2_3_4-13 

How reproducible:
Always

Steps to Reproduce:
1. by  inspection
2.
3.
    

Additional info:

Comment 1 Akira TAGOH 2003-11-25 09:09:45 UTC
*** Bug 110789 has been marked as a duplicate of this bug. ***

Comment 2 Akira TAGOH 2003-11-25 09:10:22 UTC
*** Bug 110790 has been marked as a duplicate of this bug. ***

Comment 3 Akira TAGOH 2003-12-02 10:57:47 UTC
fixed in 2.3.4-14.


Note You need to log in before you can comment on or make changes to this bug.