Bug 110792 - bad source code
bad source code
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ipchains (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 11:07 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 04:04:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 11:07:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package ipchains-1_3_10-19 from Fedora.

The compiler said

1.

ipchains.c:2193: warning: `+' flag used with `%x' printf format
ipchains.c:2193: warning: `+' flag used with `%x' printf format

The source code is

                        fprintf(fp, FMT("0x%+-10x ","mark 0x%+x "),
                                (int)fw->ipfw.fw_mark);

The + flag is used for signed quantities, the %x flag is used for
unsigned quantities. You can have one or the other, not both. Pick 
one.


Version-Release number of selected component (if applicable):
ipchains-1_3_10-19 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 Mike A. Harris 2003-12-15 08:22:05 EST
These types of rather IMHO harmless warnings, should be reported
directly to the upstream maintainer of the given software, so that
it gets fixed upstream and not just in one distribution.

Low priority issues like this also get a higher priority when
accompanied by a patch that fixes the issue.  ;o)
Comment 2 Mike A. Harris 2004-02-17 04:04:56 EST
Fedora Core 2 will have a 2.6.x kernel, and we have dropped ipchains
support in our Fedora Core kernel because it isn't widely used or
tested nowadays.  We no longer support ipchains in future OS releases,
so I'm closing all ipchains bug reports that are open which are not
security related or mission critical.

Closing as 'WONTFIX'

Note You need to log in before you can comment on or make changes to this bug.