Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 110799 - bad source code
bad source code
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: imlib (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 11:17 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 11:45:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 11:17:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package imlib-1_9_13-14 from Fedora.

The compiler said

1.

io-ppm.c:179: warning: operation on `a' may be undefined
io-ppm.c:180: warning: operation on `a' may be undefined

The source code is
                              ptr[a++] = ptr[a - 1];
                              ptr[a++] = ptr[a - 1];
Better code is
                              ptr[a] = ptr[a - 1];
                              a++;
                              ptr[a] = ptr[a - 1];
                              a++;

2.

io-ppm.c:197: warning: operation on `a' may be undefined
io-ppm.c:198: warning: operation on `a' may be undefined
load.c:1467: warning: operation on `a' may be undefined
load.c:1468: warning: operation on `a' may be undefined
load.c:1485: warning: operation on `a' may be undefined
load.c:1486: warning: operation on `a' may be undefined

Same problem as #1.


I seem to remember reporting these exact same bugs in Redhat 8.0,
but they still don't seem to be fixed.



Version-Release number of selected component (if applicable):
imlib-1_9_13-14 

How reproducible:
Always

Steps to Reproduce:
1. by inspection
2.
3.
    

Additional info:
Comment 1 David Binderman 2004-11-20 05:09:00 EST
I can confirm that these bugs still exist in Fedora Core3.

Is imlib a deprecated package ?

This bug report is nearly a year old, and nothing has happened.
Comment 2 John Thacker 2006-04-21 11:45:51 EDT
imlib is basically deprecated now, and I believe going to be removed in the next
version since Gnucash finally went to gtk2/GNOME2.
In any case, it's only a warning, and I don't think that Fedora generally
patches upstream code just to remove compiler warnings.

Note You need to log in before you can comment on or make changes to this bug.