Bug 11080 - Upgrade -> 4.0-0.8 causes tar to archive entire filesystem!
Summary: Upgrade -> 4.0-0.8 causes tar to archive entire filesystem!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-27 16:18 UTC by chris
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-21 17:01:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description chris 2000-04-27 16:18:12 UTC
I've just upgraded all my XFree86 packages from 3.3.6-20 to 4.0-0.8.  When
upgrading the XFree86 package, tar started to create an archive of the
entire filesystem (i.e. starting at /), until I interrupted it.  This was
whilst executing the "%triggerpostun -- XFree86 < 3.9" script.

I'm not completely sure what caused it, but the following line is
definitely wrong and may have had something to do with it:

/var/lib/xkb /var/state/xkb ../../../../../var/state/xkb

(too many ..'s in the path for the symlink).

A colleague experienced exactly the same symptoms.

Comment 1 Sammy 2000-05-01 19:20:59 UTC
same problem seen by me and many other people, as reported on the news group!

Comment 2 Frank Ch. Eigler 2000-05-03 14:43:59 UTC
Even if the "../../.." problem is solved, the code that performs the movement of
files between the two directories is wrong.  In the shell script function, it
does something like

	(cd SRC ; tar cf - DIRS ) | ( cd DST ; tar xf - )

This is wrong, because if SRC or DST do not exist, the tar jobs will be executed
without the correct cwd, leading to the potential copying of entire /.

The code should instead say

	(cd SRC && tar cf - DIRS ) | ( cd DST && tar xf - )

Note the "&&" instead of ";".

Comment 3 SB 2000-05-06 20:33:59 UTC
This could explain some of my problem trying installing new XFree86 packages
*mutter* solved that prob but now I get a:
XFree86
#################################################unpacking of archive failed on
file /usr/X11R6/bin/xterm: cpio: link failed - Bad file descriptor

and I end up left with broken XFree86 half-installed and unusable...how to I
elminate this problem, FYI /usr/X11R6/bin/xterm does not exist so it should have
no trouble creating it in that regards...any ideas? Please...

-Stan Bubrouski

Comment 4 SB 2000-06-21 17:01:18 UTC
This bug can be closed because XFree86-4.0-0.16 fixed this, XFree86-4.0-0.19
is the current version as I am writing this.

-Stan Bubrouski


Note You need to log in before you can comment on or make changes to this bug.