Bug 110802 - bad source code
Summary: bad source code
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: htdig   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 16:23 UTC by d.binderman
Modified: 2015-03-05 01:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 14:26:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-11-24 16:23:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:


I just tried to compile package htdig-3_2_0-19_20030601 from Fedora.

The compiler said

WordDBPage.cc(85): warning #61: integer operation result is out of 
range

The source code is

       if(cmp || size>8*1024*1000000000)

I make that nine zeros, which makes the rhs about 8e12, which won't 
fit
into a 32 bit integer. Overflow is bound to occur. Only solution
seems to be to use 64 bit long integers.




Version-Release number of selected component (if applicable):
htdig-3_2_0-19_20030601 

How reproducible:
Always

Steps to Reproduce:
1. by source code inspection
2.
3.
    

Additional info:

Comment 1 Phil Knirsch 2004-01-13 17:22:41 UTC
Fixed in latest package. Checking the code seems to suggest that the
first if contains the 1000000000 wrongly.

Removed that, checkes follow if everything still works.

When  verified will close as rawhide.

Read ya, Phil

Comment 2 Phil Knirsch 2004-01-14 14:26:31 UTC
OK, verified that the fixed rpm works.

Rawhide version htdig-3.2.0b5-3 and later contain the fix.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.