Bug 110804 - Should be able to set share name manually
Summary: Should be able to set share name manually
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-samba   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 110815 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 16:26 UTC by Behdad Esfahbod
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-15 21:03:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that implements this (27.56 KB, patch)
2004-05-24 22:17 UTC, Philip Van Hoof
no flags Details | Diff
Patch that implements this feature request (27.90 KB, patch)
2004-05-27 20:37 UTC, Philip Van Hoof
no flags Details | Diff
Patch that implements this feature request with some extra's which are related (35.63 KB, patch)
2004-05-30 12:44 UTC, Philip Van Hoof
no flags Details | Diff
Minor change since last patch (36.61 KB, patch)
2004-05-30 13:11 UTC, Philip Van Hoof
no flags Details | Diff

Description Behdad Esfahbod 2003-11-24 16:26:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
User should be able to set/edit share name.  Currently the last part
of the share path is take as share name.  Should also take care if two
share paths have the same last part (/var/shares and /opt/shares).

Version-Release number of selected component (if applicable):
1.1.4

How reproducible:
Always

Steps to Reproduce:
1. create a share.
2.
3.
    

Actual Results:  no share name is asked, or can be edited.

Expected Results:  Should let user edit share name.

Additional info:

Comment 1 Brent Fox 2003-11-24 20:24:03 UTC
*** Bug 110815 has been marked as a duplicate of this bug. ***

Comment 2 Brent Fox 2004-02-10 18:11:15 UTC
Can you provide more information about why it is necessary to expose
this in the user interface?

Comment 3 Behdad Esfahbod 2004-02-10 22:52:12 UTC
Because this is the name that is seen from a remote machine, so a
users typically want to set it.

Even if you cannot set it, at least it should somehow handle the case
when you want to share both /home/user1/music and /home/user2/music. 
Then when you want to handle this, the cleanest way I can think of is
to select something like music-1 music-2, ... and let user adjust it.

Comment 4 Philip Van Hoof 2004-05-24 19:06:06 UTC
Since I need this myself, I am planning to implement this, any objections?

Comment 5 Brent Fox 2004-05-24 19:51:37 UTC
Philip: sure, go ahead.

Comment 6 Philip Van Hoof 2004-05-24 22:17:14 UTC
Created attachment 100521 [details]
Patch that implements this


Have fun :-)

[freax@pluisje redhat-config-samba]$ cd src/
[freax@pluisje src]$ cvs diff -u >
/home/freax/system-config-samba-bug-110804-proposal-by-PhilipVanHoof.diff
cvs server: Diffing .
[freax@pluisje src]$

Comment 7 Philip Van Hoof 2004-05-27 20:37:41 UTC
Created attachment 100640 [details]
Patch that implements this feature request


This fixes a tiny bug in my previous patch. Not it seems to be fully working

[freax@pluisje redhat-config-samba]$ cvs diff -u >
/home/freax/system-config-samba-bug-110804-proposal-by-PhilipVanHoof-take-2-05_27_2004_-_22h34m.diff

cvs server: Diffing .
cvs server: Diffing doc
cvs server: Diffing doc/figs
cvs server: Diffing pixmaps
cvs server: Diffing po
cvs server: Diffing src
[freax@pluisje redhat-config-samba]$

Comment 8 Philip Van Hoof 2004-05-27 20:40:52 UTC
Note to both: if you have questions about this implementation, feel
free to contact me

Comment 9 Philip Van Hoof 2004-05-30 12:44:18 UTC
Created attachment 100702 [details]
Patch that implements this feature request with some extra's which are related

This also changes some other behaviour like generating the sharename on
text-changed in the dir-entry and adds a column in the treeview

Comment 10 Philip Van Hoof 2004-05-30 13:11:05 UTC
Created attachment 100704 [details]
Minor change since last patch

This will also make sure that if you are in edit-mode, and the sharename
already exist .. that it will be made unique by adding "-#" at the end of the
textbox-value

Comment 11 Philip Van Hoof 2004-06-08 08:21:59 UTC
For people who want to use this asap, I have setup a viewcvs that can
create a tarball of the latest version:

http://cvs.freax.be/cgi-bin/viewcvs.cgi/system-config-samba/system-config-samba.tar.gz?tarball=1

Comment 12 Nils Philippsen 2004-08-06 07:25:32 UTC
Package ownership changed.

Comment 13 Nils Philippsen 2004-08-15 18:17:30 UTC
Applied the patch to CVS and brought it a bit more into shape ;-).


Note You need to log in before you can comment on or make changes to this bug.