Bug 11082 - mkinitrd doesn't understand the "linear" raid type
Summary: mkinitrd doesn't understand the "linear" raid type
Status: CLOSED DUPLICATE of bug 12775
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-27 20:31 UTC by Steve Wills
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-27 20:31:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Wills 2000-04-27 20:31:55 UTC
Summary basically says it all. If you have a raid setup using raidtype
"linear" you get an error:

raid level linear (in /etc/raidtab) no recognized

Here's a patch:

--- /sbin/mkinitrd.old	Tue Feb 29 16:10:14 2000
+++ /sbin/mkinitrd	Thu Apr 27 16:04:36 2000
@@ -216,6 +216,9 @@
 	    [0145])
 		findmodule "" raid$number
 		;;
+            linear)
+		findmodule "" linear
+		;;
 	    *)
 		echo "raid level $number (in /etc/raidtab) not recognized" >&2
 		;;

Steve

Comment 1 Arenas Belon, Carlo Marcelo 2001-02-12 23:37:58 UTC

*** This bug has been marked as a duplicate of 12775 ***


Note You need to log in before you can comment on or make changes to this bug.