Bug 110821 - bad source code
Summary: bad source code
Status: CLOSED DUPLICATE of bug 79643
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL_mixer (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 17:01 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-11-24 17:01:57 UTC
Description of problem:

I just tried to compile package SDL_mixer-1_2_4-9 from Fedora,
and the compiler said

effect_position.c:102: warning: operation on `ptr' may be undefined
effect_position.c:107: warning: operation on `ptr' may be undefined
effect_position.c:108: warning: operation on `ptr' may be undefined
effect_position.c:137: warning: operation on `ptr' may be undefined
effect_position.c:139: warning: operation on `ptr' may be undefined
effect_position.c:155: warning: operation on `p' may be undefined
effect_position.c:155: warning: operation on `p' may be undefined
effect_position.c:155: warning: operation on `p' may be undefined
effect_position.c:155: warning: operation on `p' may be undefined
effect_position.c:173: warning: operation on `ptr' may be undefined
effect_position.c:178: warning: operation on `ptr' may be undefined
effect_position.c:179: warning: operation on `ptr' may be undefined
effect_position.c:204: warning: operation on `ptr' may be undefined
effect_position.c:206: warning: operation on `ptr' may be undefined
effect_position.c:222: warning: operation on `p' may be undefined
effect_position.c:222: warning: operation on `p' may be undefined
effect_position.c:222: warning: operation on `p' may be undefined
effect_position.c:222: warning: operation on `p' may be undefined
effect_position.c:247: warning: operation on `ptr' may be undefined
effect_position.c:248: warning: operation on `ptr' may be undefined
effect_position.c:269: warning: operation on `ptr' may be undefined
effect_position.c:270: warning: operation on `ptr' may be undefined

This bug first reported in Redhat 8.0



Version-Release number of selected component (if applicable):
SDL_mixer-1_2_4-9 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Thomas Woerner 2004-04-22 12:11:30 UTC

*** This bug has been marked as a duplicate of 79643 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.