Bug 110840 - groupadd refuses to create a group named 'Domain Users'
groupadd refuses to create a group named 'Domain Users'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: shadow-utils (Show other bugs)
3.0
All Linux
low Severity low
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 14:45 EST by Jay Fenlason
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 15:07:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Fenlason 2003-11-24 14:45:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
The groupadd command refuses to create group names that are similar to
the group names used in Windows network.  This forces network
administrators using Samba to use the "username map" feature of Samba
and provides confusion for users who don't understand why the Linux
and Windows group names are different.

Also, the groupadd manual page does not provide any documentation on
what constitutes a "valid" group name.  Network administrators must
find valid group names by trial and error.

Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-14

How reproducible:
Always

Steps to Reproduce:
1.run "groupadd 'Domain Users'"
2.Observe the not-very-useful error message
3.
    

Expected Results:  The group should be created.

Additional info:
Comment 1 Eido Inoue 2004-10-21 16:51:20 EDT
group domain names can now be mixed case and include a dot (other than
the initial character), but spaces are currently not allowed.
Comment 2 Jay Fenlason 2004-10-21 17:09:14 EDT
Why not?  AFACT, the only verboten characters in user and group 
names should be ':' and '\0'. 
 
Samba likes to use group names that are as similar to their Windows 
counterparts as possible.  Samba's job, after all, is to make them 
*be* the same group.  Forcing the group to have different names on 
different machines only confuses the users. 
Comment 3 Eido Inoue 2004-10-22 12:07:19 EDT
Comment 2: are you sure about that? What about the "@" character? What
about the fact that Windows allows almost* /any/ Unicode character for
a username and groupname? (don't forget that Windows usernames and
groupnames are case insensitive, and we're getting requests from other
people to allow for case-SENSITIVE user/group names)

* I say almost because there are rules regarding normalization and
certain forbidden characters.

I'd prefer to follow a standard that you could point me to for POSIX
system usernames rather than make ad-hoc changes for one particular
authentication system and hope we don't run into trouble later down
the road.
Comment 4 Eido Inoue 2004-10-27 15:07:21 EDT
According to POSIX:

3.426 User Name

A string that is used to identify a user; see also User Database. To
be portable across systems conforming to IEEE Std 1003.1-2001, the
value is composed of characters from the portable filename character
set. The hyphen should not be used as the first character of a
portable user name.

3.276 Portable Filename Character Set

The set of characters from which portable filenames are constructed.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
a b c d e f g h i j k l m n o p q r s t u v w x y z
0 1 2 3 4 5 6 7 8 9 . _ -

I will add provisitions to allow for the POSIX stuff.

Note You need to log in before you can comment on or make changes to this bug.