Bug 110851 - Installer detects scsi_hostadapter in wrong order
Installer detects scsi_hostadapter in wrong order
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 16:05 EST by Sebastian Wenner
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 12:15:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Wenner 2003-11-24 16:05:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20030925

Description of problem:
On a machine with more than one scsi_hostadapter the one used for
installing is not entered as first adapter in /etc/modules.conf
This leads to errors after installation with scsi-devices named in the
wrong order.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. A machine with more tha one scsi_hostadpater (In our case an
onboard Adaptec, an IBM ServeRaid and two FiberChannel QLA2312)
2. The actual scsi disk is attached to the ServeRaid (ips) and some
LUNs on the QLogics (qla2300), nothing attached to the Adaptec (aic7xxx)
3. Install to /dev/sda (harddisk @ ips)
    

Actual Results:  Entries in /etc/modules.conf:

scsi_hostadapter aic7xxx
scsi_hostadapter1 qla2300
scsi_hostadapter2 ips

Expected Results:  Entries in /etc/modules.conf:

scsi_hostadapter ips
scsi_hostadapter1 qla2300
scsi_hostadapter2 aic7xxx

Additional info:

This causes big confusion because according to /etc/modules.conf the
mkinitrd command works.
That leads to a wrong order of loading modules within the initrd in
the script linuxrc.
If I boot after a normal installation the LUNs on the qla2300 are
detected first and get named /dev/sda ... /dev/sdh, my previous
/dev/sda is now /dev/sdi. The normal mounts work mainly because they
are mounted by filesytem label, but my swap is not working and some
other mounts from the LUNs will not work.
I either have to modify that directly befor I reboot after install
oder have to boot from a rescue media oder disconnect my QLogics while
booting. Neither is preferable ;)
Comment 1 Jeremy Katz 2003-11-24 17:25:34 EST
Devices are detected in PCI order as presented by the kernel.  If you
wish to specify the order by hand, boot with 'linux noprobe' and
manually load modules in the order that you want.
Comment 2 Sebastian Wenner 2003-11-25 03:29:13 EST
This answer is not satisfying!
RedHat Adv.Server 2.1 was able to do this in the right order, so AS
3.0 should also be able to do this.
Comment 3 Rick Dennis 2004-01-29 21:40:55 EST
I agree this should be fixed.  At work we setup an initrd with qla*
modules removed.  It would be helpful instead of having "linux
noprobe" a "linux disable=qla2200 disable=qla2100....".  Because
noprobe disables *all* probing.  
Comment 4 Jeremy Katz 2004-02-12 12:15:25 EST
The "right" order is completely arbitrary, there is no "right" order.
 If you have a specific reason to load modules in a specific order,
then you need to load them by hand.

Note You need to log in before you can comment on or make changes to this bug.