Bug 110861 - php_values in .htaccess Copied From One Virtual Host to Another
Summary: php_values in .htaccess Copied From One Virtual Host to Another
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 111140 121303 (view as bug list)
Depends On: 123095
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 22:08 UTC by Allan Hansen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 18:46:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Allan Hansen 2003-11-24 22:08:19 UTC
Description of problem:

I am not sure whether this is a problem with php alone or with php+httpd.

When using virtual hosts in Apache, php_value set in .htaccess are
sometimes copied from one virtual host to another.

Example

/web/a.com/.htaccess:
php_value auto_prepend_file "/web/a.com/prepend.php"

/web/b.com/.htaccess:
-- noting --

When loading a.com, the prepend.php file is always prepended as it
should. But then loading b.com, /web/a.com/prepend.php is sometimes
prepended as well - but not always.


Version-Release number of selected component (if applicable):

Applies to both the Fedore Core 1 package and to test versions:
httpd-2.0.48-1.2 + php-4.3.4-1.1


Steps to Reproduce:
1. Set AllowOverride Options in httpd.conf on <Directory>
2. Use virtual hosts in httpd.conf
3. Set php_value auto_prepend_file "some-file" in .htaccess for one host.
4. Do NOT set php_value auto_prepend_file in .htaccess for another host.
5. Start two browsers and reload one host in each browser. At some
point the host without php_value auto_prepend_file will get it from
the other host.

Comment 1 Kalle Kataja 2003-11-28 14:58:02 UTC
*** Bug 111140 has been marked as a duplicate of this bug. ***

Comment 2 Allan Hansen 2003-12-15 21:45:22 UTC
Three weeks and not a comment. 
Reporting bugs is completely pointless.

Comment 3 Joe Orton 2003-12-15 22:15:49 UTC
Thank you for the reports.  We've spent some time investigating but
have not yet tracked down a fix.

Comment 4 Joe Orton 2004-01-30 09:24:25 UTC
Somehow managed to track it down upstream. Test packages are up at:

http://people.redhat.com/jorton/FedoraC1-php/

Comment 5 Joe Orton 2004-04-20 09:18:28 UTC
*** Bug 121303 has been marked as a duplicate of this bug. ***

Comment 6 Joe Orton 2004-05-25 18:46:40 UTC
Fixed in 4.3.6-1.1 update.


Note You need to log in before you can comment on or make changes to this bug.