Bug 11087 - Bug in /etc/rc.d/init.d/squid
Summary: Bug in /etc/rc.d/init.d/squid
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL: none
Whiteboard:
Keywords:
: 11274 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-28 07:14 UTC by Alexander Kanevskiy
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-28 20:43:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Kanevskiy 2000-04-28 07:14:21 UTC
Newver version of squid (2.3+) has aonother syntax cache_dir directive.
so when user change default value
cache_dir ufs 100 16 256
for exmaple to incrase cache dir size we got a "squid -z" on every squid
start.

fix:
in squid.init:
CACHE_SWAP=`sed -e 's/#.*//g' /etc/squid/squid.conf | \
        grep cache_dir | sed -e 's/cache_dir//' | \
        cut -d ' ' -f 2`

change "cut -d ' ' -f 2" to "cout -d ' ' -f 3"

Comment 1 Bill Nottingham 2000-04-28 20:43:59 UTC
Ack, you're right. Fixed in 2.3.stable2-5.
Thanks for the bug report & fix!

Comment 2 Bill Nottingham 2000-05-16 16:46:59 UTC
*** Bug 11274 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.