Bug 110876 - Setup process would not accept parm iucv=TCPIP.
Summary: Setup process would not accept parm iucv=TCPIP.
Status: CLOSED DUPLICATE of bug 107162
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 3.0
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-24 23:59 UTC by Need Real Name
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-11-24 23:59:51 UTC
Description of problem:

We use IUCV for network connectivity for the Linux guests on       
z/VM 3.10.  No matter where I place the statement "iucv=TCPIPLNX"  
in the REDHAT PRM file, the install program wouldn't never accept  
"iucv=TCPIPLNX" just like other parameters in the REDHAT PRM file. 
I had tried all upper, lower, or combination of upper/lower case   
for iucv=TCPIPLNX" with no success. The install process will not   
prompt with IUCV=TCPIPLNX in uppercase, but it failed to establish 
the network connectivity between the Linux guest                   
and TCPIPLNX (IP Stack) machine.                                   
'SPOOL PUNCH * RDR'                                                
'PUNCH KERNEL IMG B (NOH'                                          
'PUNCH REDHAT PRM A (NOH'                                          
'PUNCH INITRD IMG B (NOH'                                          
'IPL 00C'                                                          
                                                                   
The circumvention is to exclude "iucv=TCPIPLNX" in the parm file   
and key it in when prompted during the install.                    
                                                                   
                                                                   
File REDHAT PRM - a CMS file on z/VM.                              
                                                                   
ROOT=/DEV/RAM0 RAMDISK_SIZE=40000 RO IP=OFF DASD=100,200,501       
iucv=TCPIPLNX                                                      
HOSTNAME=linuxtdc.bankofamerica.com                                
NETTYPE=iucv                                                       
IPADDR=171.177.29.16                                               
NETWORK=171.177.29.1                                               
GATEWAY=171.177.29.1                                               
MTU=1492                                                           
DNS=171.174.3.251:171.132.7.10                                     
SEARCHDNS=bankofamerica.com                                        

                                                                
Console log of the Linux guest machine.                         
                                                                
Starting the zSeries initrd to configure networking. Version is 
1.01                                                            
Enter iucv kernel module options (usually iucv=HOST,            
where HOST is TCPIP for the VM TCP/IP service machine           
or the name (in capital letters) of another                     
Linux guest:                                                    
iucv=TCPIPLNX                                                   
IUCV lowlevel driver Version: 1.39  initialized                 
divert: not allocating divert_blk for non-ethernet device iucv0 
iucv0: 'TCPIPLNX'                                               
NETIUCV driver Version: 1.21  initialized                       
iucv0: connected with remote side                               





Version-Release number of selected component (if applicable):


How reproducible:

Include "iucv=TCPIP" in the cms file REDHAT PRM, then start to 
install by IPL 00C from the guest machine. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:

I was prompted to enter iucv=TCPIP.

Expected results:

It shouldn't prompt to enter iucv=TCPIP.

Additional info:

Comment 1 Jeremy Katz 2003-11-25 15:13:35 UTC
Workaround is to use something like IUCV=iucv=TCPIP

*** This bug has been marked as a duplicate of 107162 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.