Bug 110881 - Certain fonts no longer display (1 pixel per character)
Certain fonts no longer display (1 pixel per character)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 23:23 EST by Russell McOrmond
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 11:48:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell McOrmond 2003-11-24 23:23:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
I am not sure how to diagnose this.  I upgraded from RedHat 9 to
Fedora Core 1 and fonts that previously worked no longer do.  I have
many documnents that use Times which now show up as a blob-of-dots
where the document was previously.  It looks as if OOo is rendering in
a 1-pixel-per-character font.

If I "select all" text and change the font (for instance, to one of
the Bitstream fonts) the text comes out OK.

At the moment only Times and Helvetica seem to have a problem which
make me wonder if a specific package containing these fonts isn't
quite right, or some cache is corrupted.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open document created previously using RedHat 9
(Example: http://www.flora.ca/russell/drafts/manley200311.sxw with PDF
at http://www.flora.ca/russell/drafts/manley200311.pdf )
2. Do a "select all" and change the font (Example: Bitstream Vera
Sans) and the text becomes readable.

Alternative:

1. open Writer, choose Times or Helvetica, start typing and junk comes up.
2. Choose other font and type with expected results.

Additional info:
Comment 1 Dan Williams 2003-12-04 10:55:10 EST
Times and Helvetica aren't actually fonts that exist on your system,
and so are forced to be substituted.  1.1.0-6 helps this.  Can you
upgrade to OOo 1.1.0-6 and see if the problem persists?
Comment 2 Russell McOrmond 2003-12-04 11:42:10 EST
I'm updating my local copy of the Fedora archive now (to see if I can
find the new OOo), but I'm confused.  If Times and Helvetica don't
exist on my system, why is OOo showing them in the font list?

Is it possible that I have defective versions of these fonts somwhere
on my system?  If they didn't exist I would have known to set up an
appropriate substitute, but these are fonts that show up as existing.

Is there a font tool that will tell me what files are used to offer a
given font?  I'm still wondering if I have a dammaged cache file or
similar somwhere.  Maybe I don't have those fonts, just something is
telling OOo that I do.
Comment 3 Dan Williams 2003-12-04 12:48:34 EST
Turns out the reason that OOo was showing these fonts is that the
generic printer PPD that OOo comes with has these fonts specified in
them, because most printers have Times and Helvetica in ROM.  So,
logically, OOo shows the fonts that your printer can print with too. 
But they don't work so well onscreen when you don't actually have the
real font file lying around.
Comment 4 Russell McOrmond 2003-12-04 13:20:36 EST
I suspect I am having version mismatch issues.  I thought I was
running OpenOffice 1.1 from Fedora, but I am possibly running partly
from OOo 1.1 that I installed before I upgraded to Fedora.

My ~/.sversionrc

[Versions]
OpenOffice.org 1.0=file:///home/russell/OpenOffice.org1.0
OpenOffice.org 1.0.1=file:///home/russell/OpenOffice.org1.0.1
StarOffice 5.2=/home/russell/office52
OpenOffice.org 1.0.2=file:///home/russell/OpenOffice.org1.0.2
OpenOffice.org 1.1Beta=file:///home/russell/OpenOffice.org1.1Beta
OpenOffice.org 1.1.0=file:///home/russell/.openoffice

I didn't notice but running /usr/bin/oowriter seemed to want the local
setup to be in ~/.openoffice/ so I did the setup there.  I had
previously had the setup in ~/OpenOffice.org1.1.0/

I now believe I am running the fedora version, and it is actually this
version that I was running that I first noticed the problem.  I was
running OOo 1.1 from the OOo ISO and didn't see this problem:


[russell@amadpur ~/.openoffice]>rpm -qf
/usr/lib/openoffice/program/soffice
openoffice.org-1.1.0-6

Comment 5 Russell McOrmond 2003-12-04 14:52:36 EST
OK.  I deleted the OOo 1.1 installed from the OOo CD, and deleted the
~/.openoffice/ directory.  Rather than asking me to run setup (as it
normally does) it just launched.   This new launched OOo writer
doesn't have those fonts listed any more, and if I load an old
document created with OOo that uses Times it displays fine (although
it does substitute with a different font than it did before).

This bug may be switched to an enhancement request to pass back to OOo
which is to try to detect when a font substitution was in error and
alert the user rather than displaying 1-pixel fonts.

Thanks for all your help Dan!  Great to see as quick response from
RedHat folks participating in Fedora as was the case with the older
RedHat.
Comment 6 Dan Devine 2004-02-17 01:09:14 EST
This looks kinda similar to bug ID #109628

I generally get fonts working in OOo except the Symbol font.  Like the
above poster, it comes out of printer as dots rather than characters.
 Screen looks kinda garbled too.

Anyone having trouble with Acrobat Reader 5.08 installed after refresh
to Fedora?  Acrobat indicates it can't find symbol for me, OOo fonts
appear garbled and patches missing from pdf's.....no printing possible
unless it contains the standard embedded fonts like above.

Thanks
Comment 7 Russell McOrmond 2004-02-17 10:06:15 EST
There seem to be general font issues with OOo.

Had an additional one related to spell checking.  I had been
cutting-and-pasting from webpages into a document only to find that
while the text was displaying in a readable font that the font didn't
exist and thus the spell checker didn't check the spelling. Spell
checker would be checking one sentence (that was in a font that OOo
knew) and not checking another (that was in a font OOo didn't know).

Having 1-pixel fonts, fonts which 'look' english but don't spell
check, and other such things makes OOo hard to use.  While I figured
this font-change out a less technical user would never have thought of ot.
Comment 8 Dan Williams 2004-02-27 11:48:18 EST
Please try current OOo 1.1.0, and reopen if problem still occurs

Note You need to log in before you can comment on or make changes to this bug.