Bug 110892 - Samba crashes, causing data corruption in files.
Summary: Samba crashes, causing data corruption in files.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 112818 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-25 10:55 UTC by Richard Allen
Modified: 2014-08-31 23:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 18:43:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Allen 2003-11-25 10:55:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Samba is randomly crashing in my environment.  Syslog has:

Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/fault.c:fault_report(36)
Nov 25 10:22:35 linux smbd[20671]:  
===============================================================
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/fault.c:fault_report(37)
Nov 25 10:22:35 linux smbd[20671]:   INTERNAL ERROR: Signal 11 in pid
20671 (3.0.0-15)
Nov 25 10:22:35 linux smbd[20671]:   Please read the appendix Bugs of
the Samba HOWTO collection
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/fault.c:fault_report(39)
Nov 25 10:22:35 linux smbd[20671]:  
===============================================================
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/util.c:smb_panic(1422)
Nov 25 10:22:35 linux smbd[20671]:   PANIC: internal error
Nov 25 10:22:35 linux smbd[20671]: [2003/11/25 10:22:35, 0]
lib/util.c:smb_panic(1429)
Nov 25 10:22:35 linux smbd[20671]:   BACKTRACE: 22 stack frames:
Nov 25 10:22:35 linux smbd[20671]:    #0 smbd(smb_panic+0x110) [0x803430]
Nov 25 10:22:35 linux smbd[20671]:    #1 smbd [0x7ef3e4]
Nov 25 10:22:35 linux smbd[20671]:    #2 /lib/tls/libc.so.6 [0x144a38]
Nov 25 10:22:36 linux smbd[20671]:    #3 /lib/tls/libc.so.6 [0x18daca]
Nov 25 10:22:36 linux smbd[20671]:    #4
/lib/tls/libc.so.6(malloc+0x8d) [0x18ce7d]
Nov 25 10:22:36 linux smbd[20671]:    #5 smbd(Realloc+0xa8) [0x802408]
Nov 25 10:22:37 linux smbd[20671]:    #6
smbd(convert_string_allocate+0x435) [0x7ecdb5]
Nov 25 10:22:37 linux smbd[20671]:    #7 smbd(unix_strlower+0x44)
[0x7ed114]
Nov 25 10:22:37 linux smbd[20671]:    #8 smbd(strlower_m+0x55) [0x7fb705]
Nov 25 10:22:38 linux smbd[20671]:    #9 smbd [0x724eee]
Nov 25 10:22:38 linux smbd[20671]:    #10
smbd(ntlmssp_server_update+0x191) [0x725631]
Nov 25 10:22:39 linux smbd[20671]:    #11
smbd(auth_ntlmssp_update+0x4b) [0x843fcb]
Nov 25 10:22:39 linux smbd[20671]:    #12 smbd [0x6d0041]
Nov 25 10:22:39 linux smbd[20671]:    #13 smbd [0x6d05a9]
Nov 25 10:22:40 linux smbd[20671]:    #14
smbd(reply_sesssetup_and_X+0xdb5) [0x6d14b5]
Nov 25 10:22:40 linux smbd[20671]:    #15 smbd [0x6f21bf]
Nov 25 10:22:41 linux smbd[20671]:    #16 smbd [0x6f2463]
Nov 25 10:22:41 linux smbd[20671]:    #17 smbd(process_smb+0xa4)
[0x6f26b4]
Nov 25 10:22:42 linux smbd[20671]:    #18 smbd(smbd_process+0x19f)
[0x6f340f]
Nov 25 10:22:42 linux smbd[20671]:    #19 smbd(main+0x4fd) [0x876f4d]
Nov 25 10:22:42 linux smbd[20671]:    #20
/lib/tls/libc.so.6(__libc_start_main+0xf0) [0x132750]
Nov 25 10:22:43 linux smbd[20671]:    #21 smbd [0x6982e2]
Nov 25 10:22:43 linux smbd[20671]:


People are reporting damaged files on the samba servers now.   This is
a rather serious bug IMHO.
As to how frequently its happening.  Here's a quote from logwatch:
 --------------------- samba Begin ------------------------

      
**Unmatched Entries**
lib/fault.c:fault_report(36)
+=============================================================== : 132
Time(s)
lib/fault.c:fault_report(37)  INTERNAL ERROR: Signal 11 in pid 17719
(3.0.0-15)
+Please read the appendix Bugs of the Samba HOWTO collection : 1 Time(s)


132 samba crashes in one day.








Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
Run samba for a long enough tine
    

Additional info:

Comment 1 Fabian Kronner 2003-11-27 12:38:57 UTC
You probably have defective hardware (memory). Please use a memory 
test program (like memtest86) to verify and post the result here.

Comment 2 Richard Allen 2003-11-27 13:47:15 UTC
I seriously doubt that, unless upgrading a machine from 7.3 to Fedora
is bad for memory's health.   This box has been running flawlessly for
years and only started acting up when Fedora (or samba 3) was installed.


Comment 3 Fabian Kronner 2003-11-27 16:16:36 UTC
Okay, sorry! Looking into the smb logs on a fedora machine shows the 
same symptoms. Downgrading to samba-2.2.8a cured these symptoms.


Comment 4 Richard Allen 2003-11-27 17:33:20 UTC
So its not just me ?    Fantastic :)     FYI, I also opened a bug over
at the Samba bugzilla on this.   
https://bugzilla.samba.org/show_bug.cgi?id=809
They want to know how to reproduce, and if you have any thoughts on
that,  you should log them in that case :)


Comment 5 Michael Young 2003-11-28 15:02:16 UTC
triage->upstream https://bugzilla.samba.org/show_bug.cgi?id=809

Comment 6 Philip Ross 2003-12-29 20:56:15 UTC
I'm seeing crashes with similar stack traces on a machine I upgraded
from Redhat 8 to Fedora Core 1 today (Samba version 3.0.0-15). So far
all the crashes have occured whilst playing mp3s in WinAMP on a
Windows XP box.

I've posted the details of the stack traces to the upstream bug.

Comment 7 Guðmundur D. H. 2004-01-04 04:03:02 UTC
*** Bug 112818 has been marked as a duplicate of this bug. ***

Comment 8 Marek Kassur 2004-01-26 22:03:06 UTC
I upgraded from 7.3 and same problem, more detailed comment including
stack traces here: https://bugzilla.samba.org/show_bug.cgi?id=809

I'll test samba-2.2.8a-2 tomorrow.


Comment 9 Marek Kassur 2004-01-28 19:26:48 UTC
It was character conversion problem as suggested by Gerald (Jerry)
Carter and Philip Ross on the Samba bugzilla. I have fixed all ISO
encoded file names to UTF-8. Now everything works as expected.


Comment 10 Jef Spaleta 2004-01-29 18:43:59 UTC
Since this conversation has moved upstream to samba's bugzilla, I'm
going to mark this bug as resolved upstream.





Note You need to log in before you can comment on or make changes to this bug.